SculpfunS9 not recognized by Lightburn using Macbook Pro

Please help. I have a Macbook Pro running on Monterey IOS. I have a Sculpfun s9 laser which is not recognized by Lightburn. I have done a manual set up, choosen every port possible, switched out cables, adapters, started/ restarted LB. I have correct driver installed. Checked same set up on friend’s PC and worked perfectly. What am I missing? Anyone have any thoughts? Thx.

Have you seen our Sculptfun Setup video? Setting Up Your SCULPFUN Laser With LightBurn & First Project - YouTube

Yes I have watched it and followed all instructions. Thank you for the link however. Any further thoughts?

If you’ve installed the correct CH340 driver for your macOS computer, then you can right click the “device” button in the “Laser” window to ask LightBurn to re-connect to your laser. The status bar on the bottom of the screen will also show connection status. In the “Port” menu in laser, what ports are shown and selected? (you’ll want the ones that aren’t associated with Bluetooth)

Thank you. I basically uninstalled everything and tried a lower version of the driver and kept trying all the ports. One finally made a response so I remain hopeful that contact is established. Thank you again.

Hello again. Well, I am sorry to report that I still am unable to connect to my Sculpfun S9 laser using my MacBook Pro running Monterey. I know the laser works because one time it miraculously reacted to my commands to trace the perimeter of my imported piece…however I have never been able to repeat that despite not changing any of the connections, ports, etc for that one run. I have tried the manual laser entry using GRBL and anything else listed with GRBL and systematically tried every port on the computer, every console selection, using the USB option. I only changed one thing each time and tried for hours…nothing. I am a bit frustrated because I have been at this for almost 2 weeks-my trial will run out soon-and I have not been able to achieve anything. I truly am at a loss. I will say I am a complete beginner with laser engraving and perhaps I am overlooking something minor. I certainly would appreciate any further thoughts, advice, etc. I REALLY want to use Lightburn because it is such an amazing and versatile program. Thank you in advance for your insight and help.


If you got this working once then it stands to reason that the major components should be in place. Let’s confirm.

Can you provide the following:

  1. Screenshot of System Report->Hardware->USB showing the laser connected
  2. Output of Terminal command. Your laser should show up as a serial device:
ls /dev/*usb*
  1. Full screenshot of LightBurn with a design ready to print
  2. Screenshot of Device Settings window
  3. Push Save Gcode button in Laser window and save to a file with .txt extension. Upload file here.

I agree to PY, I guess you just selected the wrong ports in LightBurn.

Additionally, here is a step-by-step guide on adding the laser to a Mac: Setting up the software - Diode Laser Wiki Maybe there is some section you didn’t test so far…

Hello. I just wanted to thank you for your helpful comments. I finally got the laser to work!! I tried what someone else had suggested with trying the order of turning Lightburn and the laser on , connecting things and taking off the auto homing device and that is what made things connect. Thanks again.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.