Search settings for a Chinese GRBL

Hello, I just bought a 15W diode laser cut with a GRBL 1.1 card. The software provided is really not very practical and I am testing LightBurn which seems very complete. By cons, I encounter some adjustment problems. Does anyone else have a chart speed and power for engraving and cutting according to materials? I made several tests with corrugated cardboard at first … And in cut mode of a text, when moving from one contour to another, the laser is not cut and therefore leaves a trace on the surface. How to change that?

For the laser being left on between cuts, make sure that you are either running GRBL 1.1f or higher, and using the “GRBL” device, or use the GRBL-M3 device for 1.1e or earlier.

Check the settings in GRBL - type $$ in the console and press enter, and check the following values:
$32 - this value is “Laser Mode” and should be 1 (you can set it by typing $32=1)

$30 - this is the number that GRBL uses to mean “maximum power”. It defaults to 1000, but lots of companies change it to 255. There’s a device setting in LightBurn that must match this number, called S-Value Max, shown here in the Device Settings in the lower right:

If either of those settings isn’t right, the beam may not turn off during travel moves.

For material settings, your best bet is to find others with the same hardware and ask. LightBurn works with man, many lasers, and what works for my 40w or 100w CO2 machines will be completely different on yours.

I have this :


For 100W CO2 cutting, I already have a software equivalent to LightBurn (RDCam) that has been supplied with, and an equivalent interface (this machine belongs to my work).
And after many tests … I understand that between CO2 100W 10.6μm Diode and 15W 450nm … There is nothing comparable that it is in power or speed.

This max value of 1000 I have to leave it as it is, or do I have to change it by 255? Because I always have the error message …
To change on LightBurn and also in GRBL?

I just tested by putting S-max at 255 in the software and in GRBL … it does not change anything!


You said, “because I always have the error message” - what message is that?

As long as $30 and “S-Value Max” are set to the same number you won’t really see a difference. The number itself doesn’t really matter, as long as it’s not something like 1. It is the number of unique shading values that your PWM signal will produce, so 255 is fine, 1000 is better.

The important part is that $32=1. The settings you listed didn’t have that set, but I see that you did enter that setting at the end. Double check that it was accepted by typing $$ again and verifying that it changed.

“Cut might be out of bounds - Continue anyway?”

Do you have limit switches and homing enabled on your machine? If not, LightBurn will be getting strange numbers when trying to read the position of your machine, and will present this error if it thinks the job will exceed the work area of your machine. There’s a switch in the next release to disable this for machines that don’t have limit switches or homing set up.

You should be able to avoid this by powering on the machine with the laser in the front-left corner (the origin).

No, I do not have a home position sensor. I specified it during the configuration of the machine. I always use startup “start at the current position”