Set up grid problem

Hi Everyone!
I think I have a problem with my grid setup from the first installation, but not sure what it is…
At the start up, the software did not find my machine (Foxalien 4040le) so I manually entered the driver (grbl). Then selected the work bed size (350 x 350) and home position (front left).

Now when I go to the grid, it shows my home position for the laser, but if I draw a box for example on the grid, near my home position within the work bed and start the job, it says it is outside my work space. If I use the the jog too cursor and click the front left corner of the box, the whole unit heads for the back right corner and hits my limit switch.
I’m not sure what’s happening? Check everything twice, reloaded the software, same result.
It is like it thinks my work bed is huge, but I check those settings they correct…
Any help would be great!! Thanks in advance.

This is because the machine does not know the correct coordinates after turning on and may be in the wrong coordinates relative to the Lightburn workspace, so you must do the homing first.

Thanks Ashkan!
Can you explain the homing function you are talking about? I have selected home as front left…
Cheers

You must first enable home settings in grbl and set the appropriate values ​​for it:


Adjust the dimensions of your machine workspace:

Click the Home button and wait for your machine axles to go home and collide with limited switche:

After the successful completion of the homing, in the move section, click on the get position button, you should see a value of zero for all three axes: