Set up Neje Master2s plus 30w with Lightburn

Hi, I would love to buy Lightburn software as I think it is a good user interface, however I cannot set it up without it crashing headlong into the bottom left of my Neje Master2s plus laser, I have read how to set up GRBL 1.1F machines but it is so very confusing instructions! Does anyone have this laser set up properly? Is it even possible? I have put in the correct workspace coordination 255 x 420 however the laser wants to over run these figures??

Can you describe under what circumstances this is occurring?

Please explain what you’ve done. There should be very little configuration required for your machine.

Please confirm that your laser goes through a homing process when you power it on.

Please take a screenshot of Edit->Device Settings and post it here.

Workspace appears to be upside down, when burning has finished laser goes to front left and crashes into stop bar on laser. This lasers home is set to rear left.

You are using “User Origin” for your Start from: coordinates. Change to Absolute Coords and retest.

You can change your post-burn position by enabling the “Return to Finish Position” in Device Settings if you like.

Retest and report back results please.

Yes have done this, on using Absolute Coords the word prints from back to front, also to set Return to Finish ends the carriage top right of laser and shudders terribly. Has anyone a screen shot version of the settings for this particular laser do you think? Problem being on changing so much I am going around in circles, not remembering which function I changed last. So sorry if you think I am a lost cause, but I really want to be able to use this software properly…hence why I have asked for a trial period extension.

Your device settings look appropriate for your laser.

This site is often cited for Neje Master 2S setup:
(Updated) Lightburn Setup for the Neje Master 2S (Auto-Homing, 32 bit version) — North Lakes Woodwork

Normally controls not working in the proper direction is related to incorrect origin setup but that doesn’t seem the case for you.

Have you changed any GRBL configurations? Either in Machine Settings or through Console?

if so, run a homing cycle and then type these commands into Console one at a time. Copy and paste all the output from the window here:

1 Like






Target buffer size found





















































This is the results

The set up from Northlakewoodwork appears to be for a workspace size of 170 x 170 mine is 255 x 420, I am not sure how to change this in the settings.

The specific page is for the non-Plus model. There are comments about the Plus model in the comments.

You can change workspace size in Device Settings.

Before advising on any other changes… Can you confirm if you’ve made any GRBL configuration changes either in Machine Settings or by typing $##=# type commands in Console?

If so, which ones? If uncertain, a general idea of what you might have been addressing would be helpful.

No have not made any changes in GRBL settings, don’t know how to be honest.

Ok. At least it seems homing is working correctly but let me know if this is not the case.

I suspect the remaining issues are related to motor direction inversion.

If you use jog controls what direction does each button result in?

  1. Left
  2. Right
  3. Up
  4. Down

Jog control all correct, going in the correct direction. I have never tried the z or A jog buttons?

Z is not relevant for you.

A you should not have unless you’ve enabled rotary. Disable this by going to Tools->Rotary Setup and disable Rotary there.

Test setup. Are you still getting crashing?

No more crashes, but still some noisy shuddering, I have set the return to position now at X0.2 Y420 so goes back to home position quietly now, the x position did not like 0.0 for some reason.
I really am grateful for your helping me to get set up, I am I suppose one of the more senior members so does take me awhile to grasp setting etc…but I would love to be able to use Lightburn to its fullest, (my children think I am mad🤣)

They’ll change their tune once they see what you’re able to produce. Have fun with the laser.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.