Setting a layer to 100% power and not frying my laser

I have an 80watts laser, Ruida RDC6442G controller. It comes with a F2 tube, that maxes out at 28mA, but should be run at 25mA or less, according to the seller. For peace of mind, I like run it at 22mA, to extend its life.

To get 22mA reading on my ammeter, I need to set the layer power in Lightburn to 48%. That’s fine. I know I must not go over it.

I know (or think) there is a setting in Lightburn I can change, so when I set the layer power to 100%, it fires at 22mA. My goal is to prevent someone (or a sleep deprived me) to set the power higher than it should.

Am I right, or just having a brain fart here?

P.S. I’ve tried messing with the power setting using the MAX POWER button on the machine display panel and it doesn’t seem to have any effect on this. I also reduced Laser 1 maximum power (%) from 99 to 50 in VENDOR SETTINGS, to no avail too.

What power supply do you have. There should be an adjustment to lower it manually vs software.

MHO seems to coincide with @micrololin, you need to adjust the lps for your maximum current.


I have a tube that has a 21mA limit. When I checked my current at 50% power I was drawing around 14mA. That told me that every time it lased it was drawing 28mA.

Lowered the lps so that at 50% power, I was reading 10.5mA. Lightburn will now allow me to go to the maximum power set in the controller (98%)

Make sense?

:smile_cat:

I have a HY-DY10 power supply.
According to what I managed to find online, it has a small aperture for “adjusting output current”, probably a potentiometer

So, I could try adjusting it until I find 100% on lightburn is equal to 22mA. ??¿¿??

Yes. Read @jkwilborn post above.

I will try… again, if you don’t hear from me in 2 or 3 days, come feed my dog.

That SHOULD have worked. That’s what the field does, and I use it. Something’s off.

First off, let’s note that MACHINE CONFIG Max/Min Power is different than the LAYER Max/Min. But both are used. And in the end you get the actual Laser PWM duty.

If you’re at 100% Config and 100% Layer power at see 28mA, then roughly 75% final PWM duty might get you about 22mA. If you set Machine Config Max Power to 75%, then that’s what “100% Max Power” in the Layer will generate at the final PWM.

If the Machine Config Max Power isn’t limiting the current, I’m confused. Worked as intended on our Ruida. I don’t think Ruida would change that. I would widen the troubleshooting… maybe the PWM isn’t being used at all because of a wiring error and the laser fires full-bore whenever it’s enabled?

We’re a community makerspace, we don’t want to allow users to be able to overcurrent the tube either. However, we actually do NOT use the Machine Config Max Power to create that limit. We just use the analog pot available for our LPS, which is not exposed on the front panel for user access. Just use 100% in Config, set the test fire button to Continuous, fire it just long enough to get a current reading and dial it in. This seems cleaner to me in regular user mode than scaling all the Layer duty so it fits into a scale that only goes up to 75%.

@Patico

When the laser is set for 75% power, it will fire 100% power (28mA) for 75% of the period. May look like 22mA at the dash. But it is 100% of what the lps can produce.

All the meters I’ve worked with are not quick enough to measure a single ‘on’ time and invariably seem to display the rms value.

Don’t fall into the idea you can actually control the lasers power with a pwm wave. The only real control is speed.

IMHO, he needs to set it at the lps.

:smile_cat:

AFAIK the recommended tube current limit is the average that the meter (analog or digital, we have both) reads.

The Reci W6 and its HVDC-excited tube LPS has a response time of under 1ms for rise or fall from when you turn on or off the 5V modulation input to actual beam power switching on or off, so it only shows a clear on/off up to about 300Hz.

And I measured that by changing the Ruida PWM freq to 300Hz and drew a long horizontal line at 1000mm/s and 50% “power” (PWM duty). That means that the PWM has a “spatial period” of 3.33mm, much longer than the width of a focused beam (~0.2mm), so you’ll totally see the PWM alternating from full-on to full-off in the burn as it creates dashes. If you do 100Hz (yep you can tell Ruida to do that!) at 1000mm/sec, you get really distinct dashes, but the edges are still blurry for about 1mm. The edge, either rising or falling, looks blurry for that same 1mm when you speed up the PWM and shorten the dash. At about 300Hz, you only have a small portion of the dash where it’s clearly reaching a full on or off output.

We can’t tell if that limitation is in the LPS or the tube, since I don’t have any way to switch 20KVDC. No bipolar or MOSFET or IGBT can do that. Or any common vacuum tube- which would also defeat the point as switching speed of a vacuum tube would also bring up a switching limit.

These LPS run on high freq flyback transformers. I don’t know if they could be modded to switch faster, they do have a rectifier diode and probably a cap after the transformer.

But, the LPS spec actually says “response time <1ms” which would explain that already as a supply limit. If you could physically switch off 20KV at higher freq with some magic unobtanium-based technology, I don’t know how fast the tube would respond. And if it did switch faster, it would be of no practical value without a practical, reliable HVDC LPS supply that could drive it.

The specs I’ve seen stated =<1mS, so it could be as bad as 1mS

I think that been pretty well determined by the fact you can burn one up in no time with too much current, so it’s the supply not the tube.

I ‘think’ mine is a little quicker and the only thing that it different is the lps in mine is a 60 watt supply with a 50 watt tube. To respond to 90% voltage, a higher power tube has a higher lase voltage requiring a quicker build to the 90% hv.

I’ve run mine at 50% power with a period of 1mS and at 500mm/s nice brown line, at 1000mm/s dotted…

I’ve watched this on my scope and I’m still not sure how it’s working. What I see isn’t what I expect.

On my Ruida, when I press start, the pwm starts and remains active even if it isn’t lasing.

:smile_cat:

Are the dogs still getting fed?

Yep. Then again, I haven’t stick my fingers inside the PSU yet

There should be an external access to it. Unplug the machine when you reach in.

I see a small hole in a rather hard to reach place. I need to make my way into the chassis to see what is inside: probably all I need is a small screwdriver.
Gladly, at the time I am, a bit full of work, so it’s not the best time to perform tests.

(This proves I am getting older and wiser… well, at least older)

I use ‘ceramic’ screwdrivers. I don’t like probing around inside boxes like that…

My adjustment is next to impossible to get to… such is life…

Good luck

:smile_cat:

1 Like

I was today years old when I learned there are ceramic screwdrivers: these seem really nice for working on electronics or live circuitry.

Looks like I am ordering a set right now. However, will look for some other set with longer tips.

Thanks a lot! The dog will thank thee for keeping me alive