Setting correct $30 value for Neje 30W in GRBL1.1f

Hello
I am trying Lightburn on my DIY CNC laser cutter with a Neje 30W air assist.
My CNS is controlled by arduino uno / Protoneer CNC shield 3.5 (original) and has GRBL 1.1f onboard.
I set

$30=255
$31=0
$32=1

On your documentation you write

S-Value Max

…GRBL defaults to 0 to 1000 for newer versions of GRBL, or 0 to 255 for older ones. The S-Value Max setting in LightBurn must match your controller setting, or you’ll either get not enough power output (if LightBurn’s setting is lower) or very small power numbers will set your laser to full power (if LightBurn’s setting is higher).

So I mujst change $30=255 to $30=1000?
Or do I change “S-Value max” to 255 in Device settings for GRBL in lightburn?

image

Are these two way equivalent?
Thanks you
Pietro

As long as they match it doesn’t really matter. I personally have both set to 1000.

1 Like

Thanks!
Pietro