Setting up Cheap Chinese Laser

Hi,

I’m very new to laser cutting/engraving and lightburn so bear with me if these questions have been asked/answered.

I bought one of those cheap laser cutters second hand from someone who had not got around to even putting it together. He had paid for an upgraded 15W laser.

Needless to say, the “program” that came with it was useless for a number of reasons, the main one being that I don’t speak Chinese and the language in the program kept resetting itself. This lead me to find an alternative and lightburn has so far saved the day. That’s the back story.

The cutter is running from an Arduino cnc shield rev3.0. As far as I can tell it is a Arduino uno and cnc shield in one (happy to be corrected on this). So far, I’ve got lightburn to recognise the cutter and I can run the laser through a cut or engrave program. The laser does everything it’s supposed to with one fairly significant problem. The laser doesn’t turn on or off, and I can’t adjust power settings. The Arduino has a port labelled pwm and so does the chip on the laser itself however it doesn’t seem to do anything. When plugged in the laser is off, I can unplug it and get it turned on but again it doesn’t turn on and off during a program and obviously this leaves marks and whatnot where there shouldn’t be.

I’d appreciate any help I can get. I’m very much a novice (today is my second day playing with it and I’ve never used an Arduino or anything before so if you would be kind and walk me through it very slowly I’d appreciate it.) I’m hoping it’s some setting or silly thing I’ve missed but who knows.

Thanks in advance

What firmware/software is on the arduino? If I had to guess it could be GRBL, you can check this by going to the ‘Console’ window and see what it says there. If its something like “Grbl 1.1f [$ for help]” you can check with ‘$$’ if all the GRBL settings are good. The most important setting is then for $32 (if you use a laser), this should be ‘1’. If its 0 you can set it by typing
$32=1
Probably you also have to set other parameters, but these are very dependent of size/configuration of your laser. Search for people with similar setup and how they configured this in GRBL.

Thanks. I’ve checked all those values and they are set as they should be. The Arduino is running GRBL 0.9. I haven’t had any luck flashing it with newer version. I’ve tried xloader and the Arduino IDE software.

With setting the $32 value, does that activate/control the laser through the pins labelled S_En (spindle engage I believe)? The pwm plug on this board is in another location and I’m wondering whether I should ignore it and use the S_EN pin instead.

Thoughts?

$32 is not an available option in GRBL 0.9. You will want to use the device in LightBurn called “GRBL-M3” as your device profile, and set the S-Value Max setting in the device settings to 255.

1 Like

Thanks Rick. I didn’t realise that. Repeating previous question though… do I connect the laser to the S_EN pin?

Sorry, that is beyond my current knowledge. :no_mouth: I am sure someone in here will offer comment.

Having done a bit more research and a bit of playing around, I’ve learnt that the board that controls the laser is not a genuine Arduino, it’s a Chinese knock off (I did suspect this but didn’t want it to be true). It simply isn’t capable of doing what it claims.

New plan is to just bite the bullet and spend the $50 to get a genuine Arduino CNC Shield board and go from there (really should have done this straight away). I’m hoping that the amount I’ve learned trying to get this one working should make it relatively easy to set up a proper one from scratch.

Thanks for the help you all did give, I think I was fighting a losing battle from the start.

Wish me luck!

You might check https://tkkrlab.nl/wiki/Mini_A5_Laser this is my experience with a arduino (nano) cnc. I upgraded from grbl 0.8 to 1.1f, to get it all working I had to reroute one of the pins (you can find this in the this documentation).

Regards,
Dave

I’ve recently bought cheap chinese laser (7W). Their software was unusable, but now I’ve got LightBurn working on it by upgrading GRBL from 0.9 to 1.1 without any problems. I even didnt have to change control board. Just follow wiki instructions on:
https://github.com/gnea/grbl/wiki/Compiling-Grbl

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.