Setting up Library on Ruida 6442

Windows 10
Ruida 6442
I’ve created a library for a box I’m cutting out. Three different layers for the parts of the box, power speed and offset for the lid, engraving and main box cut. Seems simple enough but I’m doing something wrong. Everything applies ok, press start and the “Z” maxes out (raises up until it hits the limits). I don’t have any setting in for Z. If I delete the library export the file and bring it back in it works fine. Any ideas.

Have a read here:

Thanks Rick. I was looking to disable Z but couldn’t see it. I’ll have a look for relative mode. Thanks for the heads up.