Setting up Lightburn with Eleksmaker A3 Pro?

Hi.

Is there a tutorial on setting up lightburn with an Eleksmaker A3 Pro? I just built the newly bought unit and would like to try lightburn but have seen indications online that it’s not such a straight forward path like issues around firmware and versions of grbl…learning curve started but some guidance would be welcome.

I have tested the unit with EleksCam and it worked fine.

Any suggestions most welcome.

Adri

Hi Nicolas, I have done this and it is very easy. However, your are correct in that you need at least grbl 1.1f. I found this is very easy to do using the free trial of T2 laser. (just search on the web for it) once you connect that to your A3 with the default 0.9 grbl you can then use T2 to update the firmware to 1.1f. The firmware comes with T2. Once you have done that Lightburn will work directly with the A3. You will love LB compared with just about anything else out there.

Cheers

David

Thanks. Does the most recent A3 ship with a nano that will take the firmware upgrade then? I read some stories about it not having enough memory to take 1.1f. Also, isn’t there a 1.1g? shouldn’t I get the very latest grbl?

Nick

I have the Mana SE 3 axis with the Nano and 1.1f. I haven’t bothered to update to g. I did it try it one time, but had some problems with circles not drawing correctly. Also g doesn’t come by default with T2 laser so you would have to use another loader. At this stage to get you going with Lightburn, I would just stick to 1.1f. It works perfectly.

1 Like

Just another question if it’s ok.

Once set up and if configured correctly to work with the A3 Pro will lightburn stop me from going out of bounds? for example say I have an image to burn and accidentally I ask the software to burn outside of the A3 working area will lightburn stop me from sending the stepper motors crashing into the end of the aluminium extruded frame?

Hope the question is clear.

Anyone?

Thanks in advance

Adri

Stop you, no. But you can ask LightBurn to let you know when these conditions arise. You have the option to 'Enable ‘Out of Bounds’ warning by going to the ‘Device Settings’ window and then look to the right side of that dialog.

1 Like

Hi Rick, doesn’t that option really need homing switches to work correctly? If you start up with the laser near the left edge of the frame and then drive it left how can it know it is going to hit the frame or not?

Hi,

In T2Laser there are 5 different versions of 1.1f. Which version do I install?

Thanks in advance.

It does, but so would anything else having the ability to tell you that you were headed out of bounds. You can do it without limit switches if you consistently power up the laser with the head at the origin position (power on position is treated as 0,0), and don’t unlock the motors after powering up.