Setup and settings for a Genmitsu LC-60A, Linux setup, and staccato laser noise

Does anybody have recommended settings for the LC-60A?

After getting poor results with the out of the box settings, I manually changed the settings to the ones listed in the manual, and now things are well and borked.

Any suggestions for how to revert? I would love to get the control board back to the state it was in out of the box, but I can’t find settings online anywhere, and the ones I used from the manual seem very different from what I remember the original settings being.

It’s a 5.5w diode laser with a 600mm square bed.

Also, any insight into why the laser might be making a staccato knocking noise while firing? Definitely wasn’t happening out of the box, started after using settings from the manual. It’s fairly loud.

And finally, recommendations for Linux setup? I’ve been borrowing a family member’s laptop with windows just for testing.

Current settings from manual:


$0=10 (step pulse, usec)

$1=25 (step idle delay, msec)

$2=0 (step port invert mask:00000000)

$3=2 (dir port invert mask:00000010)

$4=0 (step enable invert, bool)

$5=0 (limit pins invert, bool)

$6=0 (probe pin invert, bool)

$10=3 (status report mask:00000011)

$11=0.010 (junction deviation, mm)

$12=0.002 (arc tolerance, mm)

$13=0 (report inches, bool)

$20=0 (soft limits, bool)

$21=1 (hard limits, bool)

$22=0 (homing cycle, bool)

$23=0 (homing dir invert mask:00000000)

$24=25.000 (homing feed, mm/min)

$25=500.000 (homing seek, mm/min)

$26=250 (homing debounce, msec)

$27=1.000 (homing pull-off, mm)

$30=10000 (spindle max rpm)

$31=0 (spindle min rpm)

$32=0 (laser mode, bool)

$100=80.000 (x, step/mm)

$101=80.000 (y, step/mm)

$102=800.000 (z, step/mm)

$110=10000.000 (x max rate, mm/min)

$111=10000.000 (y max rate, mm/min)

$112=2000.000 (z max rate, mm/min)

$120=500.000 (x accel, mm/sec^2)

$121=500.000 (y accel, mm/sec^2)

$122=500.000 (z accel, mm/sec^2)

$130=500.000 (x max travel, mm)

$131=400.000 (y max travel, mm)

$132=100.000 (z max travel, mm)

GRBL-LPC controller

My assumption is you never did a ‘save’ before you started tweaking.

Backup the data you are going to modify, in case ‘things’ don’t go ‘right’.

Edit → Machine Settings, has a ‘save’ button. This will save a current copy of the configuration to a disk file, which you can then just ‘load’ to read the saved file and then ‘write’ to the controller to restore the controllers configuration data.

Lightburn actually makes some kind of backup that you may find on your machine.

I haven’t dealt with this much, but if you’re on linux you can hunt around with ‘find’ command to search the machines file system and locate these backups… As you can see I have a number of them going back in time… Here is the line I used.

jack@Kilo:~$ find ~/ -iregex ".*lightb.*backup.*\.lbset$" -exec ls -l {} \;

Part of the results

Might try looking at using one of these. I’d save it, just in case, then try and ‘load’ one of the early backups to restore the configuration.

Good luck


Unfortunately I did not save the default configs, you guessed right- there was a table of default values in the user manual so I didn’t think to. When actually reverting to those however I started to notice that values were different- I could be wrong but I kinda think that they are CNC router settings that just got erroneously copy pasted into the laser manual?

I actually did all this on a borrowed machine on windows since the drivers for the machine were windows only unfortunately.

The support for sainsmart has been very sporadic, and after a couple days I haven’t received any responses from them beyond the canned, “we are here to help”, so here’s hoping I can find somebody willing to post their $$ from a fresh machine.

Thank you for your help- I’ll look around and see if lightburn didn’t cache something somewhere.

I understood you were using Linux? Linux doesn’t have driver issues like Windows. I don’t follow what you mean by ‘windows only’

If you have a problem getting up on your linux box, we’ll do our best to assist.

Might check about ‘borrowing’ the Windows machine again and/or search it for a backup you could use.

Unfortunately, most of the time it’s ‘live and learn’… Anytime you are going to modify anything, make a backup of it. It’s just good practice for ‘recovery’ when using any computer.

If you don’t know how … ask … saves lots of grief at both ends…

Good luck


Apologies for being unclear.
The machine was plug and play for Windows so I’ve been testing on a borrowed machine just for convenience. It is my goal to get it setup on my Manjaro daily driver though.

I didn’t really foresee such immediate problems like these since I haven’t really tested beyond the confines of the short introductory manual. But yes haha, live and learn indeed, and always.

Would you give me your 2¢ on the $$ I posted?

Do those settings make sense for a bed of 600mm sq with a 5.5w diode laser on it?

If I could confirm whether the settings in the manual really are erroneous or for a router, it would be helpful.

Thanks again for your help.

I have no experience with this version of Linux. For simple communications, I’d just try the modules (drivers) that come with that version of Linux before I’d worry.

Now I don’t know if you are up on a Windows or a Linux machine…?

Do you have Lightburn up and running on Linux … is that where got the $$ listing?

If so and the $$ listing came from Linux, it’s talking to the controller.

You should go though the Lightburn Common Grbl Setup. Ensure you read the whole thing, especially the Machines without homing sensors / limit switches section.

$30 should be 1000 and ‘S-value max’ set to the $30 value, also 1000.
$32 set to 1 enables the laser mode.

Good luck


Hi, again apologies for being unclear.

I’m currently on windows. I want to get my control board working before switching over to Linux.

No worries, I’m relatively comfortable on my system- you are on mint? I’m just very new to lasers. And CNCs in general.

Ya I’ve been reading this

for most of the morning. I was kinda hoping to find somebody with the same machine to get the factory settings back, but doing it by hand is definitely my backup.

Thank you for your link, I’ll use it as my first reference.

My machine actually does have a limit switch on each axis, and it does seem to be finding them when I press home.

I appreciate your help very much. Thank you.

IMHO I think you are nuts struggling to get it working on a machine that you are not going to use…?

I’d suggest you install Lightburn on the Linux box and go from there. Most versions of Linux don’t need any kind of driver to make this work … only in the Windows/Mac worlds is this a constant issue.

IMHO, pitch windows and go with Linux. I use Ubuntu. Started with Debian, move to Ubuntu after it started to become popular and more easy to maintain.

I have a ‘Pi 4’ and it talks to all of my various controllers via USB with no issues. It’s running Raspbian I believe.

You might try contacting the vendor and see if they can help you out… they can only say no…


Haha I am totally with you.

Generally speaking I’m pretty bitter about being dragged into a Windows environment, but sometimes I make exceptions.

Thanks for your help. I’ll probably come pester you here again after doing the setup by hand if I run into any problems, if that’s cool.

No problem. I suspect if it’s any kind of well implemented Linux it should be pretty smooth.

Good luck

Take care


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.