Shapeoko 3 xxl Cant get test fire to work

Ive got the Jtech laser. Laser is connected/recognized but i cant seem to test fire through the software…

Ive changed the following commands accordingly as per the instructions but still no luck.

Any help would be greatly appreciated thank you

Thanks for reaching out and welcome. :slight_smile: You mention “as per the instructions”. Is it safe to assume you mean the JTech instructions found here?

Did you select the ‘Enable Laser fire button’ in the ‘Device Settings’ screen? It should be set to ON (green), then restart LightBurn and it will show up in the UI in the lower-right of the ‘Move’ window.


Thank you! and yup those ones! and yes also enabled the laser fire button

On your LightBurn screen, do you see the Power/Fire items I highlighted in red above? If not, did you restart LightBurn? You must. This updates the UI so these new options will be displayed. Can you get the laser to fire at all?

In their documentation, they state: “This button is good for looking at your position to find where you are in low power and to use for focusing. You might need to go up to 5% or higher to have this work for your laser.”. Have you made this adjustment?

Type $$ into the LightBurn console then hit Return. This asks your setup to spit out the current firmware settings. Copy and paste the entire response here so we can take a look.

I did restart the application and was able to see Fire button enabled and i tested it at 20% to make sure but still no luck… I can activate the laser manually when i toggle the switch on to the laser but cant get the software to activate it. On a side note I can control the CNC itself through the software just fine.

Is it only the test fire that doesn’t work, or does the laser not fire at all? The commands LightBurn uses are:

M3        ; enable spindle/laser
G1 Sxxx   ; switch to G1 and set laser power to xxx.  25 would be 10%


G1 S0     ; set laser power to zero
G0        ; switch back to G0 rapid mode, laser off
M5        ; turn off the spindle / laser

If you enter these commands in the console, you should see a beam. If you don’t, it’s not a software issue, but something in the configuration or wiring.

1 Like

Ok thank you very much I will try that out later today and report back.

Sure enough it was a wiring issue…doh! :rofl:. After reading through the installation instructions sloowly this time I realized when connecting to the control board, make sure you put the RED WIRE to the PWM post in the header. Connect the BLACK wire to the GND post.

Someone got a little too excited trying to get their laser going… Thank you for the help guys.
Attached a picture for anyone that might stumble through this thread with the same silly issue hah.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.