Shapeoko, Laser by Laser Ink (object works) won't run code

All I seem to get are syntax errors when I load any G code that resembles what I think it should be.
It will stop at Line one with a syntax error.
I have remove all the (; LightBurn 0.9.19
; Emblaser 1 A3 device profile, absolute coords
; Bounds: X6.45 Y4.61 to X139.55 Y137.39
G00 G17 G40 G21 G54
G90
M4
; Cut @ 50 mm/sec, 90% power
M8
G0X12.93Y7.72
; Layer C27
G1X13.77Y7.1S900F3000)
gobbley gook and it stops at another line with the same error.
Please share youropinions.
I’m desperate!
Alex

First off, it seems like you’re using an Emblaser profile, which is a bit weird, but shouldn’t really hurt anything.

Shapeoko uses GRBL controllers as far as I know. When you say, “when I load any GCode…” - why are you loading GCode exactly? LightBurn will directly talk to your laser and drive it.

I have, in fact, taken my computer to the shop and hooked it up to the Shapeoko/ Laser and they do communicate.
I have configured the LightBurn software for that laser (“Find my Laser”) and all seems well.
However, when I attempt to run the g code for this design it seems to trip up on the “Layer C27” command (see above).
After removing that from the code, it starts doing strange things (like a 45 degree burn from origin to ? I stopped it!)
Anybody want to buy a diode laser? CHEAP!

Not following this wording. Please try again. What does “trip up” mean exactly? Are you saying that you are no longer using the incorrect profile, now working with a GRBL profile and getting the exact same result?

How are you running the GCode for the design? You should just click ‘Start’, and it automatically removes all the comments for you as it’s being sent to the laser.

“Trip up” means it stops!
I have tried GRBL as well as the 'Emblazer" codding (in the original software (Object Works) the laser app was accessed by choosing the Emblazer option.

When I run from the Light Burn software, it faults at line #1 (“Layer 27”).
It seems to be attempting to run the comments.
Comments are identified by semi-colons so I tried replacing them with bracket.
No luck! Still faulted at line #1.

This is likely the line it’s complaining about:

G00 G17 G40 G21 G54

Though I don’t really understand why, as that’s pretty generic code. It is most definitely not trying to run the comment lines, and those shouldn’t be included in the line counts - if you save the GCode to disk and remove all of those, then click ‘Run GCode’ it will likely still stop, but now you’ll know which line the issue is.

Which version of GRBL is running on your machine?

Appreciate your comments, OZ.
First, I don’t know how to check for the version of GRBL. I have tried all of the versions of GRBL offered as options in LB.
I did remove all the precursor comments and it still stops at ‘line 0’.


These commands begin a gcode that show signs of working through Object Works although the G21 should be changed to G20 (it cuts a bunch of circles which are too small) however, when I force LB to ignore the ‘Layer C27’ instruction, the graphic disappears from the work area and, I believe that it is that instruction that is causing the fault.
G92X0Y0
G21
G00X3.783Y6.32F1400
S200
M3
Incidentally, here is the image I’m trying to cut.
image
Alex

That’s your GRBL version:
image

It is very old. You seem to be using the GRBL-LPC profile with this, which would cause you major problems. Use the GRBL-M3 device profile in LightBurn instead.

Perhaps I don’t understand how to change the settings to get the program to run GRBL-M3.
I have selected it from the “Devices” menu and have chosen it as the default but, when I “Start” the job it seems to default back to the version (above) and the stops at line 0 reporting that the ‘Layer 27’ instruction is illegal.
Perhaps I’m chasing my own tail here!!
My trial expires on Wednesday (I have already extended it once when I became encumbered by health issues during the first period).
I’m more than a little frustrated. The laser AND the Shapeoko both work well but I just can’t find the software that work with them both.

Try this:

  • In LightBurn, delete the devices in the device list, then quit
  • Make sure your laser is powered, and connected
  • Run LightBurn, go through the device setup as it requests
  • If it asks you “do you have an X-Carve, Shapeoko, or other”, pick Shapeoko
    (does it ask? I know it does for XCarve, but I haven’t heard from Shapeoko owners)

Once you’ve set up the device again from scratch, there shouldn’t be any remnants of the older setup in there, and hopefully things work better. If you’re still having issues with it, we can extend the trial again until you’ve got your setup working smoothly. I’m ok with earning your money. :slight_smile:

1 Like

That certainly worked. No more defaulting away from the GRBL-M3, however, now nothing seems to be working. Not even movement of the head. Very suspicious!
I’ll try with a different program tomorrow.
I’ll be out of my trial period tomorrow. Shall I just go through the same (previous) process?

Do you have other software running that’s talking to your machine at the same time as LightBurn?

Rebooted computer and everything came on line again (Where it said ‘disconnected’ now says ready and movement of the CNC is restored).
I’m still getting a fault at line 0 , layer C27; Unsupported command (See my Dec 17 post above).
Here’s the first few lines of the Gcode.
Can’t figure out why that line is being treated as a command. Take it out and run the Gcode? Believe I’ve tried that once already!

; LightBurn 0.9.19
; GRBL-M3 (1.1e or earlier) device profile, current position
; Bounds: X-133.1 Y-132.78 to X0 Y0
G00 G17 G40 G21 G54
G91
; Cut @ 50 mm/sec, 90% power
M8
M5
G0X-5.54Y-3.12
; Layer C27
M3
G1X-0.83Y0.63S229.5F3000
G1X-0.45Y0.28
G1X-

Share you using Carbide Motion to run the code on the Shapeoko? If so you need to output it to the correct gurgle version for the machine. If you bounce over to the Community.carbide3d forum I’m sure someone there can help you.

There’s a thought although I’d really like to get Light Burn to work. Especially since I’m hoping to get a bigger laser and Light Burn seems to be the one package universally recommend.
Thanks for your input, Michael.

Well, it’s been a week and still no joy with LB.
No fear though. I still think is the best out there. Just not for this particular combination.
I’m afraid I haven’t had much response from the Carbide 3D forum yet either but I’m OK.
I created a Gcode file in a router program, converted all the spindle commands to laser commands and it worked very well.
PLUS I learned a little more about programming in Gcode!!
Thanks for all your input. I’ll keep trying to get this done in Light Burn,
Alex