Shapeoko Pro XXL laser startup delay issue


I wasn’t quite sure if this was the correct place to post but since the Shapeoko runs on GRBL I thought it was the most fitting.

I have been a long-time Lightburn user and previously was running Lightburn on a CarveKing CNC. The laser module is from Endurance Lasers (10watt) and has been working great. I have just finished moving it over to my brand new Shapeoko Pro XXL (their latest version of this machine, it’s a beast!)

I didn’t expect to have any issues but when I tried out my first test cuts on some white paper I am noticing that the laser has a delay each time it starts off a new cut.

I am using the latest version 0.9.24. I have included 2 samples to show the issue I am having.


When I set up Lightburn for the new machine it did ask the type of machine (Shapeoko) and it in turn placed 2 macro buttons for me (Use Laser or Use CNC). In checking my settings $32=1 is correct for the laser.

I have been poking around for a bit but can’t seem to find why this is occurring.

Appreciate anyone’s input.


The problem is that you’re using a diode on white paper, which reflects the bulk of the laser energy, combined with the power ramping as the speed changes. When the laser begins a cut, the default setting in LightBurn tells GRBL to ramp the power according to the speed (variable power mode), so at the start of the cut, the diode is off, and as the speed increases, the power goes up too. Normally this gives a nice consistent burn, but with anything white, so much of the energy is reflected you might not get a burn at all.

In recent versions of LightBurn we’ve added a ‘Constant Power Mode’ toggle to the cut settings. If you enable that when cutting anything white, it should help.

Ah, yes, those are the start & end points of your shapes, and burning on white paper with a diode. Challenging, due to the reflective nature of light colored material and how they tend to bounce the light off the surface, instead of absorbing the energy from the diode beam.

This, combined with slow accel numbers in firmware, might be causing this issue. If you enable ‘Constant Power’ mode on that layer it should help. This is a relatively new addition, which stops the speed ramping, thus depositing more energy during the start and end points of your shapes. Try that and let us know how you get on.

Thank you, gentlemen. This is exactly what it was and I switch to a piece of anodized black aluminum and then some cedar plank I had lying around and both worked amazingly.

Appreciate the fast response!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.