Shapeoko workspace set to XL size but Lightburn thinks it's XXL size

I have a Shapeoko XL with a workspace of 845mm x 425mm. I’ve set it up as a new device and it’s moving in the correct directions from the back right homing point. Lightburn shows the workspace dimensions correctly, but it thinks it is on a 845x845mm square space. When I’ve homed it and click on “Get Position”, it shows 845 on the X and Y axes, not 845 on the X and 425 on the Y. so then when I try to move it to a location on the workspace that is shown it comes all the way to the far front of the bed and then grinds the gears. What am I missing?

Tell LB the correct size in your settings.

Try this,

1 - Click the ‘Devices’ button found in the ‘Laser’ window
2 - Double-click your “Shapeoko XL” profile
3 - Click ‘Next’ button to advance to next window

and again…

Check and adjust as needed, the settings you have for the work area dimensions, then continue to click ‘Next’ through completion.

That’s the first thing I did when setting it up. The working area size IS correct in the initial Device Setup settings and also when I go to Device Settings once they have been input. The work area shows up as the correct dimensions, but the actual position is way off the work area. I’ve used this machine many times with Lightburn, but have come back to it after 10 months away and the new version doesn’t seem to be working the way it’s supposed to.


According to set instructions it say to set up measurements for shapeoko cnc xxl size is x-812 and y-812 so wouldn’t the correct size for a shapeoko xl be x-812 and y-406

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.