Shapeoko xxl can't set origin (negative coordinates in workspace)

New guy here and very new to lasers. I’ve searched and struggled for a while. I apologize in advance if this has been answered.

Basically my shapeoko is reading negative coordinates whenever I hit “get position”. I’ve already configured the “Use Laser” macro. The machine moves and burns properly, but coordinates are still registering as negative. Consequently when I click “set origin” then click “go to origin” the machine will run away with the laser and hit the wall. If I click “set finish position” I get a warning that says I am outside the workspace boundaries. Could some show me how to get the coordinates set up in the positive so I can use a pre-defined origin? Currently, if I have to cancel a burn, I lose my position.

I’ve already been through a ton of links and the only answers I see is the “use laser” macro, and to make sure the machine is set up front left, but I’ve already done those. Thanks much for the help!

Searching this forum for “negative coordinates” returns very good information on this subject. Below are 2 additional resources that might help.

This will explain the workspace offset:

This is a very good setup walkthrough. And, Try setting $10=0 - I think the JTech article is still missing this.

Thanks. I have been through that particular search and those links several times with no luck. However, its finally working now. I entered $10=0 multiple times, then restarted the program and it finally took. I have no idea why things don’t always register with lightburn. Thanks for the help though as it seems $10=0 is the issue and it takes multiple tries/restarts to get it to work.

This is a firmware setting that LightBurn will read once set in the firmware. How did you make this firmware setting change? If you made this change using the LightBurn console, can you reproduce this behavior? Entering commands via the console works very well for the many users we have with a similar setup. Please explain the steps you did to reproduce and we can take a closer look.

Well if it happens again I’d be glad to. Now that everything seems to be working I can’t reproduce the problem. I think I’d have to reflash with carbide motion then attempt to set up lightburn again. Yes I was entering via the console. I’ve noticed a number of other times that things seem a little slow to connect with lightburn. For example now origin is working but the end position I set up isn’t. My guess is if I try again a few times and restart the program it will.

No need to flash your firmware. Moving forward, if you see any issues with entered console commands not setting correctly or requiring more than entering once, please let us know. Glad you are sorted and things are working for you. :slight_smile: