Size in Lightburn makes no sense to me

Hi there,
I’m facing two problems with lightburn that are related to size and measurements.

1- when i import a PNG that i worked on in Photoshop the imported png differs in size that what i worked in Photoshop. i know that PS is raster based while LB is vector based i assume but i worked with other programs for other machines that didn’t have that issue.

2- LB mm system is busted for some reason. i can’t change the size of something meaningfully, for instance, if i changed the size from the bar above to what i want in mm, say something is 10 cm big so i enter for X 100 mm and cast it, it would actually size close to 24 cms and so on…

i hope that there’s a simple fix for these “not so bright issues” im facing :slight_smile:

i don’t understand very well what is your issue, you mean that a line made with PS (assuming is 50mm long) imported it in LB is 100mm bigger? or when you engrave it is 100mm bigger?

It’s bigger when imported.
It also means that it’s bigger when engraving though…

If PS is able to, try to export in SVG then import the SVG in LB, or better DXF

PS can export in SVG but not dxf… Hmmm ill give it a shot tomorrow and get back to you :grin: thanks

Oh but the dimension issue is not solved tho… i think i didn’t explain it that well so lemme try again…

Lets say i imported any object in LB, it would appear at a certain size with x and y dimensions.

If i wanted the X dimension to be a certain size ex: 5 Cm which would translate to 500 mm right?
When i change the x to 500 the size would be much bigger both in the program and in the laser shape cast.
I assumed it measured the dimensions in radius rather than diameter. But still it appeared much bigger than what the numbers said.
The number above would still be 500 or 250 but when measured IRL its much bigger.

I know it’s probably a mistake on my part and not the software’s fault. But after alot of head scratching i still cant figure out what im soing wrong.

I’d be glad to provide with any information needed.

5cm = 50mm

Hmmm hold on i might have made a very stupid mathematical mistake… :thinking:

Or maybe ive just added extra 0 in the post without thinking it through… I need to check with the device tomorrow :sweat_smile:

IT looks weird to me this behavior, i made dxf in Fusion 360 and import it in LB with no issue at all.

ok i tried the 10 mm thingy and yes i did make a mistake in the original post by adding an extra “0”
10 mm reads exactly 2.3 cm.

so the issue still persists

a dxf file will probably be read with the actual size as designed… only problem is that most of my work is based on PNGs…

anyways i found the solution for this problem… i had the lens size entered incorrectly in the program.

however this made my laser beam much weaker… i guess i’ll have to adjust my settings.

thanks everyone who tried to help me fix this issue <3

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.