Size in Roatary

I am using Lightburn. I have an X Tool 20 Watt Laser. I am using the X Tool RA2 Rotary with the chuck and in the chuck setting. I have correctly measured and set the diameter of the mug I am using. My rotation setting is correct and when tested gives me the proper rotation. My laser is properly focused.

Here is the problem. When i set up a project, a simple line, circle or square whether I correct for distortion or not the project is 16% larger than i set it up to be. Example I set a vertical line to be engraved on my test mug. the line is set to engrave vertical 80mm. When I run the program, the laser engraves a line 92.8mm. 16% larger than I want.

While I can correct this mathematically, I cannot figure why the software is enlarging my image size to engrave. This problem only occurs using the rotary setup. If I’m engraving on the flat everything is the size, I set it to be. It’s probably some box I either forgot to check off or did check off but I cannot figure which it is.

xTool has offered some new innovations with their rotary support. The low speed regulation that was added recently drew some attention but not in a positive way.

If you’re interested in testing to see if it’s LightBurn or xTool that’s done this, Please start a simple rotary project that is an unfilled 50mm square. Engrave it at 0.5% power so it doesn’t leave a mark.

If a simple square seems oversized then, in LightBurn click File, click Save GCode and save this file somewhere convenient. Open the file and select all - copy and then paste it into a reply here. It shouldn’t be more than 20 lines.

Shut off the rotary mode, without doing anything else, run the same test square, then Save GCode the same way as before.

Seeing both of those files should show us what’s happening.

You can also get a complete Machine Settings report out of the xTool. The info report and the Firmware number could also prove useful. In the Console window in LightBurn please type the following:
pressing Enter after each request.

Please scroll back in the Console window in LightBurn so you can Select and Copy the reports.
Paste the reports into a reply here.

Sounds like your steps/revolution is not correct for your rotary axis. (by 16%).

Have you calibrated the axis?

Your RA2 settings should look something like this, with 128mm set for ‘mm per rotation’:


Check again using the ‘Test’ button to make sure the rotary does an exact 360deg rotation.

As long as the “mm per rotation” is correct and causes full turn, all the rescaling calculations LightBurn makes are based on that and the diameter of the object, so you should not have to make any calibration adjustments for steps/mm at the controller.

If 128mm does not cause a 360deg turn, then you can just change that ‘128’ figure until it does.

The quickest method for checking if a rotary is doing a full 360 is the broken masking tape method - stretch the tape from a fixed part of the rotary to the moving part and cut or break it in the middle, the two parts should meet again perfectly after a 360 turn.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.