Skewed engraving images

Hello, another newbie here. I got the Mostics 3018 Pro w/5.5W Laser for Christmas. I have a graphics degree so Lightburn was the obvious choice. I’m using Lightburn 0.9.20 on a Windows 10 laptop, and GRBL 1.1f.

Sorry about the scrap wood. Didn’t want to waste good wood while learning.

First, I ran Lightburn’s focus test several times.
Bad lines and very inconsistent.

Then my first image burn, the Monster Energy logo, started to skew badly. Then about a third of the way through, Lightburn reset, and just kept slowly burning a single tiny line along the Y-axis, from where it reset. (Pic)

After restarting and resetting everything, Lightburn only runs an unfocused light, like a pointed oval, and focusing has no effect on it anymore, so no burn even at 80%. Hopefully reinstalling will fix Lightburn…

But I tried LaserGRBL to check if it was a software problem. LaserGRBL DOES burn, but still skews everything.

Now I’m finding out it’s a 4 year old problem with Windows. Or a speed problem, but my images are skewed in the opposite direction than your speed conversation, and slowing speed did not change skew.

So here’s some info I haven’t seen. I went back to take a closer look at Lightburn’s Focus Test. I have not seen this image while troubleshooting this problem.

The first pass is a straight line along the X-axis, but the return line is angled. If it returns at the exact same measure, but at an angle, it cannot reach the starting edge, even though it thinks it did, starting the next line there, a little inside the previous lines starting point, and ending a little past the finish edge, and therefore getting further out of alignment with every new line.

It seems like the x/y ratio on the return path is not the same as for the forward pass, pulling x-axis up the y-axis slightly only on return pass regardless of speed.
Lightburn Focus Test does NOT skew.
The test lines that angle off course do not consistently angle off course.

Also, Lightburn kept burning along the Y-axis (in tiny increments), during crash while the X-axis was not moving at all. Don’t know if that matters.

I really hope you have already solved this problem and I just haven’t found the answer, but if not, I hope this helps narrow down the cause. Thanks for your time.

You have a couple problems here.

  • Type $32=1 in the console and press enter, or go to Edit > Machine Settings and turn on Laser Mode. That is why you’re seeing the travel lines burning.

  • Turn on Overscanning in the Fill layer settings. You’ll probably need to increase the amount a bit too. 3018s tend to have low acceleration. This will eliminate the overburn at the sides.

  • You likely have a mechanical issue. I would guess that a coupling between a motor and one of the drive screws is loose, or something along those lines, but it’s hard to tell because the first two problems are making it hard to see the shape of the path in some places.


Thank you! You have fixed my skewed images! The couplings were the biggest problem I started with.

No matter how tight, they were constantly coming loose. After stripping out most of them, I finally had to put real screws in. However, there’s no room for screws against the Y-axis motor because it’s in a hole. But it was also the only connection that never came loose. I had checked it, and tightened it just to be sure, but I didn’t want to pull too hard and force the only good one off.

But you are right. It was slipping slightly. I was able to put a second coupling in each and it seems to be holding now as you can see in the image below.

However, I still have one BIG problem:

ALL IMAGES are burned with LaserGRBL.
So $32=1 was already set.

I still have NO BURN in Lightburn.

Even after completely uninstalling and reinstalling, Lightburn goes through all the motions like a pro.

It shows $32=1, and actually seems to be running the laser now, on low power apparently, because it leaves no marks whatsoever.

Here is everything I can think of:

Your speed in LightBurn is set to mm/sec, but your machine is not fast, so mm/min will be easier to work with. If you think you’re already in mm/min, and just used “500” as a value, you’d be requesting 500 mm/sec, much faster than your machine can move, so it would reduce the power to compensate.

Still no burn…:pensive:

I gave up on the the LB Focus Test
(the only image guaranteed to be good).
It wouldn’t burn at 90%, or on “High power laser mode. It still won’t burn.

But…as I was about to try some text, I noticed the ridiculously high speed settings, and the low power settings. So I imported the other images to see what their defaults were.

I’ve just been going with defaults and not really paying attention to these numbers yet because the only image I ever tried to burn in LB (before reset) was the Monster logo (which just happened to be the only thing to default in above 20%, whether imported or created).
But it didn’t play nice, so I haven’t run it again. The rest default in at 20%, and even though Focus Test defaulted at 10%min/20%max and used to burn…nothing burns at 20% now.

Am I missing something?
Where do these defaults come from?

I changed the Text Layer settings (and turned on overscanning).


Voila!!! LIGHTBURN IS BURNING!!! :hugs::hugs::hugs:

Thank you so much for all your help. I have less than 2 weeks left in trial version, but I think I’m gonna be happy with it. Have an awesome day, and thanks again!

Using what speed and power settings?

I only bumped the power to 100%, left speed at 500

Nothing burns at 20% any more. Am I missing something? Where do those defaults come from?

Final update:

Burning at 10-20% power works great at slower speeds (50-100 mm/min).

Now, on to carving…
Thanks again!

LightBurn supports machines ranging from 2w diode lasers to 200w industrial beasts. We had to pick something. :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.