Slop error - can't figure out the problem

Frame slop??? :woozy_face:

This error is kicking my butt. I’ll try to be as detailed as possible with everything I’ve tried.

I’m attempting to engrave a logo on a rocks glass. It’s propped up on my rotary tool but I’m NOT using the rotary for any movement (the cup has a square bottom so I can’t anyhow). I just needed an easy way to level out a very tapered glass.

I’ve set it to User origin, centered. Selected the center point on my bed, framed the job to check I’m in the bounds of the glass and I hit run.

Immediately I get a frame slop error and the machine stops. No idea how to get past it.
I’ve tried using “cut selected graphics” and tried without it.
I checked to make sure there were no random artifacts outside the cutting area.
I’ve sent it to the controller and tried to run it from there.
I’ve tried to start it directly from the software (normally I “shift +send” all my jobs).
I’ve created a new file and copied the work to the new file.
I’ve tried positioning it in all different locations in the bed.

The file runs perfectly fine if I select absolute coordinates and hit send. But both current position and user origin give me a frame slop error. If I try to run it from the controller, I get a no travel space error under frame slop.

What am I missing?

If I set user origin and ask it to frame the job, it does it perfectly. But the error shows up on the controller. I can hit enter to override but when I do, it immediately jogs the laser back to the far back left corner. I’m ASSUMING that it’s trying to run the job from that back corner, but if so, why would it frame it in the correct position only to move it upon hitting send?

I’ve spent now 5 hours watching every available video I can find about changing the start from positions and I’m doing exactly what they all share. I’m to the point of hitting my head on the wall :sob:

Thunder 35-80W / Mac
Lightburn: 1.0.06 (my license expired in January but I just paid to renew it tonight, hoping that an update will fix the problem but I have to wait until that’s manually entered)





450 mm/s is quite fast. Is that your normal engraving speed? What do you have set for overscan in cut settings? Is it possible that between the speed and overscan settings that you don’t have enough lateral room to accommodate the required movement?

If not that, can you post the .lbrn file to review? Perhaps something in the design.

It’s glass settings. It’s just a little faster than what came in the library settings file direct from Thunder but I’ve found that engraving on flat glass, it gives me the best etch.

If i set it to run off of “absolute coords” and slap the file in the middle of the bed, it’ll engrave just fine (beautifully in fact). Leaving the file in the exact same position but changing it to “user origin” or “current position” and setting the glass in the center so that i’m not moving the file at all, I immediately get the error.

The file should be good because I’ve engraved it on some scrap flat glass and on wood. It’s just that i get an error if I try to change the “start from” option and do anything other than absolute coords.

Reading through previous threads in this forum, I think it has something to do with my settings for absolute coords, but I am not understanding how I fix it unfortunately, or if that is in fact the problem.
The file’s attached but I’m pretty sure it’s not the file that’s giving me the problems.

977 redraw for cut v2.lbrn2 (384.7 KB)

I tried to upload a video of exactly the steps I’m going through but I don’t have permissions so I’m uploading it to the cloud and will link it here when it’s done

I didn’t realize this was in line mode… thought it was fill which would rule out any issue with overscan.

Do you have issues with other jobs using current position or just this one?

If you use the map pin (set laser position tool) from the toolbar are you able to move to any position accurately across the bed?

When you move your ‘head’ to the center of the glass, did you press ‘origin’ on the Ruida console.?

Then it should run as user origin. If it’s a vector, I doubt it can run that small of an item at 450mm/s, but that would not give you the error you see.

I suspect you didn’t press ‘origin’ when the head is at the proper location over the glass.

If you are not rotating it, why not lay it on the bed?

Good luck

:smile_cat: