Slow engraving or is it just me

It took 100 minutes to engrave this image. Slow?

Any comments or help appreciated

Thanks…

Your image is 150mm x 116mm, and the laser is set to travel at 100mm/sec, so, in theory, each line of the image should take about 1.5 sec or a little longer. By my “napkin calcs” that should take about 10 minutes.

Type $$ in the console and press enter, then copy the values emitted to the console here so I can see what your machine limits are set to. (they’re also in the machine settings window you posted, but rolled up in the ‘Outputs’ section at the bottom)

$0=10 (step pulse, usec)
$1=250 (step idle delay, msec)
$2=9 (step port invert mask:00001001)
$3=0 (dir port invert mask:00000000)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=3 (status report mask:00000011)
$11=0.010 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=1 (homing cycle, bool)
$23=0 (homing dir invert mask:00000000)
$24=25.000 (homing feed, mm/min)
$25=500.000 (homing seek, mm/min)
$26=20 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$30=1000. (rpm max)
$31=0. (rpm min)
$32=1 (motor lock bool)
$33=0 (motor mode mask:00000000)
$100=80.000 (x, step/mm)
$101=80.000 (y, step/mm)
$102=800.000 (z, step/mm)
$110=5000.000 (x max rate, mm/min)
$111=5000.000 (y max rate, mm/min)
$112=5000.000 (z max rate, mm/min)
$120=500.000 (x accel, mm/sec^2)
$121=500.000 (y accel, mm/sec^2)
$122=200.000 (z accel, mm/sec^2)
$130=900.000 (x max travel, mm)
$131=900.000 (y max travel, mm)
$132=500.000 (z max travel, mm)

Since your $32 setting is called “motor lock” I’m guessing this is a fairly old version of GRBL that doesn’t have laser mode, which likely means it’s stopping and starting constantly during the burn, and that will likely be what’s taking the time. If you switch to GRBL 1.1f firmware for your controller, and enable laser mode, it won’t pause every time the spindle speed changes.

Any suggestions I picked the GRBL in set up.

Thank you

That was my suggestion - change the firmware on the controller to a more recent version of GRBL, like 1.1f. If you can’t do that, you could also try using the GRBL-M3 device in LightBurn, but if the controller stops at each power change, it’s just always going to be slow.

I have updated my cnc board. It was challenging my Chinese is not good. But I was able to at least get it to run again with an updated drive. I will burn some stuff and check the speed.

Thank you for you help.

Lots involved to update the firmware on the cnc board, at least for this retired diver.

$0=10
$1=25
$2=0
$3=0
$4=0
$5=0
$6=0
$10=1
$11=0.010
$12=0.002
$13=0
$20=0
$21=0
$22=0
$23=0
$24=25.000
$25=500.000
$26=250
$27=1.000
$30=1000
$31=0
$32=0
$100=250.000
$101=250.000
$102=250.000
$110=500.000
$111=500.000
$112=500.000
$120=500.000
$121=500.000
$122=10.000
$130=850.000
$131=850.000
$132=200.000

that took over 50 mins to complete.

not much to that for 50 mins.

You should increase those by about a factor of 10 or so, and you need to set $32=1 to enable laser mode. https://github.com/gnea/grbl/wiki/Grbl-v1.1-Configuration

Awesome…

Great help

Thank you getting me this far. CNC is now too fast for 3 watt to burn…:wink:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.