Smoothieware on omtech k40, lightburn not controlling laser power

How do you have the controller wired to the lps?

Generally the L and IN inputs of the lps…

Do you have a pot or manual power control?

:smile_cat:

I have a Manual control power LED indicator i have connected the same way it came from the factory

If so, then it must have something to do with the pwm control going to the L input of the lps.

It it firing all the time or at specific times or not at all?

Do you have a voltmeter to test that signal?

Do you have a mA meter, if so what does it read when it does fire?


Maybe @lightburn can move this to a seperate thread… This should have been marked solved and a new one created…

:smile_cat:

Here is a photo my problem is when I put different power from lightburn Example 2 layers #1 power 20% #2 Power 50 The only power that read by the machine is frond the Manually panel not from lightburn i need to Control the power from lightburn, I’m using smothieware board


Did you change the configuration of the pwm port or ?

I’m not that familure with smoothie and it’s configuration, we know they work.

The ‘power’ or pwm on these are feed into the L input (usually). You need some way to check that voltage. Do you?

:smile_cat:

I will try that but if any body has a video or something to share because im starting in this lasercut life

Do you have a meter?

If so, identify the L terminal of the lps. Can’t see it in the photo…


If you can measure the voltage it should change from say, 20% to 80%. So run it at 20% then run another at 80%. I think that’s inverted, so at 80% you might read 80% of 5v… It should change.

No need for the laser to be enabled. So leave it’s power off, if possible.

:smile_cat:

Just installed the upgraded board to my machine and after installing the software and added the machine all i get is either machine is busy or alarm lock? has anyone else had this problem?