Smoothieware on omtech k40, lightburn not controlling laser power

Good day,
Since changing the board to one using smoothieware (purchased from omtech for the omtech k40) when changing the laser power settings in lightburn they do not reflect as changes in my burns. I have to manually adjust the power on the control panel of the machine.
Any suggestions?

I assume the pwm from the smoothie is connected to the L input of the lps…?

The measurement process is the same, just get the pwm connection…

Set the power in lightburn to 50% and use a voltmeter on the pwm signal. Should be about 1/2 of a 5v swing or about 2.5v

Any change is power should be reflected via the pwm. 75% power should be somewhere around 75% of 5v or 3.75 volts. If this is working, it’s elsewhere.

Are you sure the smoothie firmware is configured properly?


I am not sure smoothieware firmware is configured properly. I’ve had the new board with the smoothieware installed only for a couple of weeks and just now diving into it.
How do I go about checking config?

I don’t have one of those, so I’m not the person to advise on the correct configuration.

If possible it’s easier to measure it and see if it’s a problem, IMHO…

My understanding is that you set the max power you wish to be 100% via the ‘pot’ or power control. Then lightburn just sets the pwm to the proper percentage.

I don’t know what’s changeable in smoothie but you can change it in grbl machine via the controllers settings. They may be happening to you.

I’ll have to look at one of these… just haven’t gotten around to it …

Maybe @berainlb can pick up on this, he’s up on these I believe…

Good luck


1 Like

Can you provide some history on the machine and any notes about the upgrade process?

Most certainly.
I am using lightburn obviously. Lol.
I’ve had the laser for about a month. It’s the standard omtech k40. I replaced the stock board about a week after opening it because I already owned lightburn for another (diod) laser.

I’m using it on a windows 10 machine.
Just installed a camera so I’m playing with that as well. It just seems like no matter the power setting in the software I have to adjust on the machine it’s self to get a different power setting.

@berainlb is after the upgrade process you used. What steps did you take and how is the board connected to the lps… btw, thanks for dropping by…

Did it come with instructions or video link?


First off. Thank you so much for helping with this. I installed the board with the layout given. Then just auto searched for the laser and smoothieware was an option. Once done and recognized I was finished. I have made no other adjustments since then. Well except setting the finish point outside of the home point as it was causing hard limit x and y when homing.

What is this layout? Can you link to it or provide an image of the layout as well as photos of your install? What’s going to be relevant is the exact wiring that you implemented. Keep in mind that we have no idea what you’ve actually done so you need to fill in those pieces.

Did the controller ship with an SC card pre-installed? Are you saying you made no config.txt adjustments for the controller?

Yes the sd card was pre installed and no I didn’t make any config changes.

I’m going to assume for the moment that the basic configuration is at least a working configuration.

Are you able to provide the other information asked for?

Also, I’d like to go back to the original problem indicated. How did you determine that laser power is not being controlled?

Photos and screenshots would be useful here.

Here are photos of the board and wiring.

And here is a stock photo of the board.

I just wired from there old board to the new board based on labels between the two and then went through the set up process on lightburn once the board was recognized.

So to clarify, you’re saying you took the connections from the old board and moved them to matching connections based on label on the new board? Did you validate or are you aware of the specific pin assignments for each connection?

Also, you missed the question earlier. How did you arrive at the conclusion that power is not being controlled? What are you reacting to? Can you share those details?

This might have been user error on my end as it seems to controlling the power.
If this is the case how should I have the power set on the laser itself? Right now it is at 30% on the control board.

The darkest burn in the photo was at 80% as seen in the photo and the lightest is at 5%.

How are you doing this? Is this a potentiometer? If so, this will limit the top-end current made available to the tube. Think of this as a limiter. It limits what Max power looks like.

So 100% in LightBurn is translated to the Max power as defined by the potentiometer. All lower powers are a percentage of that max.

That’s exactly what I needed to know. That’s awesome…
So right now I had that set to 80% in lightburn and 30% on the machine it’s self. So that means it was actually 80% of 30%?

That adjustment should be set once and left alone. Use lightburn to control the lps via the controller. If you change that adjustment it will throw off all of your known power settings.

This might help…

Good luck


This is excellent. It is making far more sense now.
Thank you SO much.

No perspiration…

Take care


How did you make it work im in the same situation i cant change the power from lightburn