Snapmaker 350T not recognised by lightburn

I have just tried to configure Lightburn to my Machine. I have connected the serial Usb cable from the computer to the controller.
I checked the serial CH340 port and it tells me its connected to COM3 and is working fine.
Laser says its ready but nothing is happening
In the help menu there is a function on data capture for a support ticket. But i am not sure how to do that.
I was originally testing the trial without connecting to a machine.
When I upgraded I tried to connect to the machine and failed.
Is there any mileage in starting from scratch an doing a fresh install?
When i go to device in Lightburn it fails to find my device.
I select Marlin as the only option available
lightburn tells me its connected COM3 and using Marlin


When you click it there’s a little message that pops up and says that the support data was copied to your clipboard. You compose an email, click on the main area and click paste or (CTRL V) and send the email to

You can also paste it into a reply here and LightBurn Staff can figure out some of the machine settings from it.

Rarely. Lots of folks try it but it seems that 90-95% of the time the desired outcome is not reached.

The auto-find may not always work. Part of that can be caused by the startup sequence. if you have a USB port on your computer that has a yellow insert in it - it’s a Keep-alive one used for charging. This will allow your device to stay powered even when the computer is off.

This may be worth review:

I sorted the problem I had to ignore windows to update the CH340 driver and do it manually. thanks for all tour help

1 Like

I am struggling with this too. Running LB on a Mac with usb c.

I am still struggling Laser only operates by a direct command M3 P100. If I set P20 Laser will only work at 20% regardless of the setting in the assigned layer. Not familiar with Gcode so not sure what to do

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.