Software can't find my laser

Honestly I have no idea what laser I have. I got it as a gift and the instruction booklet that came with it is all in Chinese. The only thing I can find on the booklet that may be helpful is “Laser engraving machine 3550,6550,3550,100100”

I’ve tried to connect my device in the software by scanning since I don’t have the info to do it manually and the software can’t find my device. Does anyone have any suggesstions, tips, or advice? I would really like to start using my laser.

Thank you

If you take some pictures of your laser, especially the keypad for the controller, we can try and figure out what laser you have, and if LightBurn will work with it.

1 Like

I tried setting it up manually using GRBL M3 and I can get it to fire when I press start. But the laser does not move along either axis during a job or if I press the arrows in the software.

Thanks for helping this newbie!

That’s an Arduino nano with some stepstick motor drivers - it looks like the controller you get with the Eleksmaker lasers. You’d need to figure out what firmware it’s running - if it connects with GRBL-M3, the console should say something when it connects. If it doesn’t, it’s likely a custom firmware that’s not supported by LightBurn.

Hi,
It appears I have the same or similar machine and issue.
I have been running it successfully with T2Laser which is where the 1.1e firmware came from.
I recall my first startup before 1.1e would fire the laser. This problem was resolved once the firmware was upgraded.
Am I correct in assuming that there is no solution to this in order to use Lightburn?
Do you have firmware available for these machines?
I really like the features of Lightburn and would be disappointed if I’m unable to use it.
Thanks,
Pete