Software is deleted every time I restart my Mac. (M1 Chip)

I recently purchased a new Mac Mini with M1 Chip & Big Sur. Every time I restart the Mac, Lightburn has been deleted from the system and I have to reinstall it. Not the end of the world, but a bit frustrating! I have tried reverting to several other versions of the software but have the issue on all of them.
I couldn’t find any other posts relating to this issue so just wondering if anybody has experienced it and/or knows of a workaround?
Other than this, the software runs fine for me on the M1 chip.

You are the first, but I suspect this is not prize worthy, working as expected would be better. I will be testing this tomorrow and a brand-new M1 setup and will report my findings. :slight_smile:

1 Like

Tim

does the app get installed in the “applications” folder ?

or is it possible you are running from the temporary mounted file on the desktop?

if so you may need to manually drag the lightburn bundle from the temporary drive into the applications folder.

i’ve used macs for decades and never once heard of a correctly installed app being deleted on reboot.

1 Like

Thanks Barrie, great advice! I will check it today as that may well be the problem.

I have not been able to reproduce this behavior. Have you tried @barrie suggestion? Please update the status of this report. :slight_smile:

I’m using a MacMini M1 without issues, and just upgraded from an 8gb to 16gb M1 (for Photoshop) and so had to reinstall Lightburn on the new machine and it seems fine. Just mentioning so as to rule out the M1 as being a likely issue, or at least if it is, its aberrant behaviour.

Update to my last post…

I had been having issues with my laser for the last week or so (since 20/05/21) and thought it was hardware or firmware, but just now finally worked out that if I uninstall LightBurn and reinstall, it works. If I load up an older file, it stops working again. I am still exploring all the implications, but my initial pondering is that perhaps an update has glitched the relationship between older Lightburn files and the Ruida controller. At this stage I am just relieved to have access to the laser again, but it seems that I might have to redraw any older files (perhaps). I have the MacMini M1 16/256 and everything else seems to be working fine.

I can confirm that Barrie’s solution worked - thanks!