Software issues connecting from Mac to ruida

Hi I have just purchased a new laser and installed the lightburn software. I used a Mac and it says it’s connected and ready but the actually file isn’t transferring to the ruida machine on the computer screen or recognising it when I try the origin and frame.

Any help would be appreciated.

There is currently a known issue with our latest release using MacOS (Big Sur and maybe others) and Ruida controllers. We are investigating and will report back with a solution shortly.

In the mean time, try version 0.9.19, 0.9.20 and see if those work for you. You can fine all releases in this archive:

Thanks Rick, I have just tried to install 0.9.20 and use the links but none of them work. Which one of these should work?

Not speaking for Rick, but the dmg extension is for Mac
image

I am not understanding what “none of them work” means, technically. What did you do, exactly, and what result did you receive?

As @RalphU identifies, the DMG file is the macOS version for that release.

Chris I’m having the same issues, although mine was working and now it’s not… let me know if you’ve found a solution yet

Can you please provide the details as to what you tried, what steps you took and the exact result including any messaging you received? You are the second person to mention an issue, but thousands have not had an issue, so we are wanting to help figure out what might be going on when you are not having success.

Hi Rick, yes you commented on my post also, asking why I was using usb and not an ethernet, I replied to say the USB cable was what came with my machine and how it was set up initially by HPC. Then another reply from lightburn came to say that I should download a driver, I installed it but it didn’t make a difference. I am now going to try and reinstall an older version of lightburn as at least I could use it then. even If I did have to restart my Mac after each job.

Hi,

I’m currently using version 24 and it seems to be working with my Mac ok. It’s been ok now for about 3 days as it went off again using other the other versions. I contacted lightburn direct and they came back to me with the revised version very quick. Hope you get sorted ASAP.

1 Like

Give this one a try:
https://drive.google.com/file/d/1FfegjDY1563SKL8QrnxtcngwG4Vra_7-/view?usp=sharing

That’s the 0.9.24 version Chris is referring to. Please let us know if this does or does not resolve the connection issues for you.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.