Software Needs Update in Order for Apple to Check for Malicious Software

Getting this error when I try to install Lightburn.V1.0.02.dmg on Macbook Pro (running Mojave)

These are worth review. :slight_smile: Installing Lightburn - LightBurn Software Documentation

And,

1 Like

The process suggested does not work in Big Sur OS11.6 as there is no option to open the application when warned that the software needs updating. There is no way I have used to get the programme to open

For me, it works fine after the second or 3rd attempt.
It’s a little weird but I do not care if it works.

Thanks. Tried again and when I two finger tapped on the icon it brought up the option to OPEN. Selecting that option, it worked. I’m in! Thanks

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.