Software not able to find my Atomstack A5 laser

I just purchased both the Atomstack A5 laser and the LightBurn GCode license software. Lightburn cannot find the laser. I turned everything off and restarted. I checked the cables. Any suggestions?

What version of MacOS are you running? You may need to install a driver for the USB-Serial chip (CH340).

More information here:
Isn’t it recognized by old Macbook? - LightBurn Software Questions [OFFICIAL] - LightBurn Software Forum

Thank you for the quick response. I am using Mojave 10.14.6 If I need the driver, where can it be found?

The linked Topic has references for the necessary drivers and quite a bit of context to help troubleshoot driver issues.

Circle back if problems persist.

The forum says there are issues with later versions of Mojave which I have. My USB port works well with other devices. I have no idea how to do the three steps they suggest of removing conflicting drivers.

Let’s see if you have any conflicting drivers.

Open a Terminal and run these commands:

ls -l /Library/Extensions/usbserial.kext
ls -l /System/Library/Extensions/usb.kext

Can you paste the output here?

Also, can you open System Report and check if you see any USB devices are connected?

Also, for the time being make sure you have no other USB devices connected and you’re not going through a hub. Can I assume you’re using a USB adapter if you’re on a Macbook Air? What year is your Mac?

Any chance we could talk? 610-329-0400. I am not very good with computers.

I have no idea how to open a terminal or open a system report.

Last login: Mon Mar 7 18:04:18 on ttys000
Michaels-MacBook-Air:~ michaelmaggio$ ls -l /Library/Extensions/usbserial.kext
ls: /Library/Extensions/usbserial.kext: No such file or directory
Michaels-MacBook-Air:~ michaelmaggio$ ls -l /System/Library/Extensions/usb.kext
USB 3.0 Bus:

Host Controller Driver: AppleUSBXHCILPT
PCI Device ID: 0x9c31
PCI Revision ID: 0x0004
PCI Vendor ID: 0x8086

BRCM20702 Hub:

Product ID: 0x4500
Vendor ID: 0x0a5c (Broadcom Corp.)
Version: 1.00
Speed: Up to 12 Mb/sec
Manufacturer: Apple Inc.
Location ID: 0x14300000 / 3
Current Available (mA): 500
Current Required (mA): 94
Extra Operating Current (mA): 0
Built-In: Yes

Bluetooth USB Host Controller:

Product ID: 0x828f
Vendor ID: 0x05ac (Apple Inc.)
Version: 1.50
Manufacturer: Apple Inc.
Location ID: 0x14330000

USB Serial:

Product ID: 0x7523
Vendor ID: 0x1a86
Version: 2.64
Speed: Up to 12 Mb/sec
Location ID: 0x14200000 / 4
Current Available (mA): 500
Current Required (mA): 98
Extra Operating Current (mA): 0

This is likely your laser which means it’s being detected by MacOS and should be available in LightBurn. Make sure your laser is on before you start LightBurn.

Attempt to “Find My Laser” in Devices. It’s possible that your laser won’t get auto-detected. In that case configure the laser manually.

Make these choices in the manual creation dialog:

  1. GRBL device
  2. Serial/USB
  3. Name of your choice
  4. 410 x 400 size
  5. Origin to Front Left (bottom left)
  6. Disable “Auto “home” your laser on startup?”

In the Laser window after you start LightBurn it will show you the connection status. If it shows “Disconnected” then try right-clicking the “Devices” button. It will force a reconnect.

Make note of the Port pull-down to the right of the Devices button. If you’re not connected then try some of the other ports in that list. Once connected, make note of the port as you may need to manually choose that port in the future.

Personally I think it is an order of operation issue.

  1. turn on your laser.
  2. Plug USB into Mac
  3. open LightBurn
  4. In LightBurn “Laser” window, hit drop down to left of ‘devices’. It should have cu.BLTH, cu.Bluetooth-incoming-port, cu.SOMETHING

The cu.SOMETHING is probably your laser. Select it and see if you get a ‘ready’

GOT IT!!! Many thanks…now I am going to figure out how to use the program.

1 Like

Can you document how you sorted it? Will serve as a reference to others who search for the same issue.

I followed your instructions exactly and it worked.

Did you follow PY’s instructions or Tom’s instructions?
Many people have this struggle with Mac and I’d like to make sure it’s captured.

I followed Tom’s instructions. They were simple and worked right away.

1 Like