Software, settings, and more

So -
I run 2 instances of LB from one computer.
Each instance connects to a different laser - both “the same” laser - i.e. make and model, but as is the case there are differences. Each has a different camera, and obviously connects do a different port (com3/com4) for the DSP controller.

What my problem is at the moment - software version 1.1.04 - is that the ‘camera settings’ are not properly saving or being restored. Each camera was aligned using the steps in lightburn, then the grid was adjusted manually to get me fairly spot on, then hit Save.
But it’s not recalling those setting, and in fact it’s recalling the same settings for both lasers.

Not a HUGE problem (well, it is when someone other than myself reboots the computer and re-opens lightburn x2 and trys to run the lasers…) but it’s a problem.

I would like a command line to start lightburn with the port, profile, camera, etc all pre-selected and for LB to remember the settings ‘per camera name’.

Is this possible? Is that how it works in the newer upgrade version? I’ve avoided upgrading because I don’t want the linked material library thing on by default. That will mess my wife and/or son up even more when they sub in for me because I’m doing other things…

Thoughts? And thanks in advance.

@Bigjohn
Do you have one device profile or two?
Everything you are talking about is remembered per device profile and would normally just work if you are using two separate profiles. As long as the com port that each machine picks up doesn’t change between reboots of your computer, it will also remember which port it connected to for that device profile and use that.

I’m guessing you are using a single profile. If so, go to the devices dialog and right click on the existing profile. Choose duplicate. When it brings up the wizard change the name so it’s obvious it is a different profile. You might want to also edit and change the name of the original.

The only downside will be that you can only have one “default” device profile even when running multiple instances. You will have to choose the other device profile for that other instance. But from there it should just work.

1 Like

Two
Having a command line to start them would benefit greatly.
When you start the first instance it’s always ‘the first profile’ which is fine, but it does not seem to know it’s camera, and the port always says Auto.
John

Select a specific port once instead of auto and it will try to use that from now on.
For the camera, I’m not sure… Can you go to Help > Generate Support Data and send that info to me?

Select a specific port once instead of auto and it will try to use that from now on
That does not happen. I do that every time I launch lightburn, since I got my license over a year ago. I power up the lasers, start instance of lightburn, make sure all the settings are selected, then open another instance (which starts with the first profile again…) make all the selections (choose profile 2, port 4, double check the camera which half the time is the wrong one…)
So - a command line to ‘start lightburn with profile 1, port 3, camera x’ would be very helpful. Then I could have 2 separate shortcuts.
Would also be cool if the title bar held the profile name, and even perhaps the name of the last file imported (not opened lbrn file, but crtrl-I imported). :slight_smile:

Ok, in general it should remember the ports. But honestly that depends on a lot of this. Note I said it will try to just that from now on… in some cases it can’t depending on the system.
I will log all of this for us to look into and consider adding in the future.

@Bigjohn
Also, I still need your support data - that would help figure out what’s up with the camera and com port being remembered.
Please go to Help > Generate Support Data and send that info to me here. Just paste it into a response.

In all likelihood it’s because you are running two instances. They each load their own copy of the prefs. So if you manually set the com port in one instance but then do literally anything that would cause the prefs to be saved again in the other instance it will overwrite that. While you can run multiple instances, it’s best to not change any device or global settings while you do because they may not be saved if they get overwritten by the other instance.

If you open one instance only. Select the device profile. Select the COM port. Then close that instance.
Then open again, select the other device, select the other COM port, then close that instance again.
Then, and only then, open both instances it should have properly saved your desired COM port.

But I’ll still need your support data.

I would also recommend updating to the latest v1.2 release as there have been some fixes for the preferences.

This is from the instance running profile 1. I also occacionally lose the camera (i.e. the button grays out) - so I just had to click 'no camera / then click lightburn camera to reconnect - and it loaded the wrong camera offsets :frowning:

Apparently I can’t post this here because it has a forbidden word in the string :slight_smile:

Ok, please email it to support@lightburnsoftware.com

I’m told by people on facebook that upgrading to 1.2, materials are ‘locked’ to the file. That breaks my workflow. And Im told you can’t have it Off by default, so you have to basically ‘unlock’ them each file.
John

This was fixed in v1.2.01
You can either copy or link the material settings. Copy is the same as it always worked.

1 Like

I’ll try it but how would I revert if I don’t like stuff?
Also - did the support data help?
“settings” i’d also like it to remember

  • state of the ‘rotate/shear’ etc options per profile.
  • recent file list - per profile.

It pretty much confirmed to me that one instance of LightBurn was overwriting the other. Hence your problems.

Given what you want to do and how LightBurn handles preferences, I believe you need another solution. It’s possible to tell LightBurn to use a different path for the preferences, but it takes a little work. We’ll make it easier in the future most likely, but for now here’s how to do it. Follow these directions exactly:

  • Open LightBurn and go to File > Export Prefs. Save the .lbprefs file to a known location.
  • Close LightBurn
  • Open File Explorer to C:\ProgramData\Microsoft\Windows\Start Menu\Programs\LightBurn\
  • This is where the Start Menu links to LightBurn are stored.
  • Copy/Paste the LightBurn link file twice and rename them. Now you can use something other than A and B if you want. It will ask you to confirm administrator privileges. Click OK each time.
  • Right click on the first new link file and click properties
  • Modify the Target line to now be:

C:\Windows\System32\cmd.exe /c "SET LB_SETTINGSFOLDER=%USERPROFILE%\LightBurn_A&& START /D ^"C:\Program Files\LightBurn\^" LightBurn.exe"

  • Click Apply and confirm admin again.
  • Do this again for the other link, but use this instead:
    C:\Windows\System32\cmd.exe /c "SET LB_SETTINGSFOLDER=%USERPROFILE%\LightBurn_B&& START /D ^"C:\Program Files\LightBurn\^" LightBurn.exe"
  • Note, I just changed LightBurn_A to LightBurn_B and that there’s no space between the B and the &&
  • Now both of these should show up in your Start menu.
  • Open the A link
  • You should be presented with the Help & Notes dialog as if it were a brand new install (you won’t need to re-enter your license). Click OK to close that dialog.
  • Next it will show you the Devices dialog. Click on Import Preferences on the bottom left
  • Navigate to and load the preferences you saved at the beginning. You will see that it loads all of your devices.
  • Select and Remove the one you don’t want for this profile.
  • Click OK
  • Now open the B link and do the same process.

Assuming you did all of this right, you should now have 2 brand new preferences directories at %USERPROFILE%\LightBurn_A and %USERPROFILE%\LightBurn_B (%USERPROFILE% will resolve to the full path on C:\ for your user directory).

Now when you run either of these LightBurn instances they will be completely independent of one another. They will not overwrite each other’s preferences and any chances you make to the device on each should persist. You will also have completely independent recent file lists, rotate/shear options, etc. Everything will be completely independent.

The only thing you can’t do is try to connect to the same physical laser or camera.

What I’ve described above is really just a development tool I added a long time ago that is used from within our development environment. In the future we will likely add a proper command line option that lets you specify the prefs location instead of using an environment variable.

2 Likes

Install the previous version again. As long as you don’t save any projects with multi-layer settings, things will load properly in the previous version.

If you don’t have the old version installer you can find all of them here: Releases · LightBurnSoftware/deployment · GitHub

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.