Software suggestion/error - Import files to origin

When I import dxf files, they seem to import to random locations on the screen. When they import to an area outside the gridspace of the laser bed, the alignment buttons don’t work. Specifically, if a portion of the file is beyond the left side of the laser area, and I click the button to align with the left side of the laser bed, the cutlines will not move, or move incorrectly. I must first manually move the cut lines completely inside the laser area before clicking the ‘align-left’ button or click “align-right” to first move the cutlines to the right side of the laser cut area.

All of this is easy to get around, but extra steps that make the UI unessiarly clucky.

I think it makes much more sense to always import the cut files aligned with either the top left or right origin of the laser bed depending on user preference.

They import to your current position on screen but final position may also be dependent on how the original DXF was created.

If you hold the shift key while selecting the file for import it will use the original coordinates from the file for positioning.

1 Like

Thanks for the tip, is this the proper place to report that the align buttons are buggy?
I know that uses like me probably have a never ending list of requests, but it seems like an easy feature request to implement. All that is needed is to automatically apply the align functions to newly imported items if the user chooses to in their settings.

Which alignment functions are you using?

This should work without fuss if you do the following:

  1. select imported shape
  2. Arrange->Move Selected Objects->Move to…

Sorry, I misspoke. I am referring to “Dock objects”
I have always called this alignment and realize that Lightburn uses different vernacular.

To recreate:

  1. import dxf and drag lines outside left edge of laser area
  2. click the “dock objects leftwards” button located in the top toolbar.

For me the lines will either not move or shift slightly, but not correctly. The “Dock object leftwards” will only work if the lines are to the right of the left laser boundary.

Are you using docking only to position the imported DXF? If so, you’re likely better served using the technique I listed above.

Docking is specifically used to reduce spacing between shapes and explicitly only works within the workspace boundary and with specific constraints.

I tired align and it is not acting the way I think you are suggesting.

After I import a dxf with several closed shapes, align stacks the shapes on each other, rather than move them as a group to the 0,0 origin of the cut area like dock-object does. Even align-center is moving all the objects to the lower-right edge of the group which is not the behavior I was expecting. Both align-left and align-right appear to do the same things which is align the objects to the right side of the group so I think ‘align-left’ is pointing to the wrong function.

I appreciate your tip about holding shift while importing the file, but it is still importing outside the cut area because the document origin is the lower left of the file, and it is aligned with the upper left of the cut area.

I import a lot of files each day to cut so it adds up to a lot of clicks to align each import with the origin. Is there a quick way to do this or a way to have it done automatically?

Go to Edit->Settings->File Settings and make sure “Group imported shapes” is enabled. That will group the set of shapes on import.

I’m actually surprised to hear that dock is behaving as you say it is. Dock explicitly should change the white space between shapes and would not treat the overall set of shapes as a group.

I followed your instructions, but now that the imported shapes are a group, the align options are greyed out. I think the align tool is only for arranging shapes relative to each other.

I think dock is the correct tool, but I am a little confused why it is not working. In the code, all that is needed is to first call the opposite align function if an error is thrown when objects are outside the cut area boundary.

I experimented with the align tool a little more and diagnosed that the strange behavior I witnessed is from importing files with several copies of the same shape. Lightburn was aligning the objects correctly, but moving them to the lower-right origin of the group which is not what I was expecting. With groups of the same shape it looks like all the objects are being aligned to the lower-right corner because that is the direction they are being moved.

I suspect you’re using a different tool than what I’ve specified.

Make sure you’re going to Arrange->Move selected objects->Move to…

Aw, yes. I was using “Align” four slots up in your screenshot :slight_smile:

Move Selected objects works way better than docking. What is the point of the docking tool? Seems like it does the same thing with limitations.

Is there a place where I can request that one of the “Move selected objects” tools be automatically applied to new vector imports? Seems like a simple feature that would be more useful than semi randomly dropping new imports onto the screen.

Thanks for your help by the way.

1 Like

Docking is actually fundamentally different and useful in its own right. It’s meant to minimize space between shapes. You can think of it as accomplishing the most basic aspect of a nesting strategy.

You can click make a feature request by going to the “Feature Suggestions” link at the top of the forum or by clicking the automatic link created in this sentence.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.