(SOLVED) Ruida RDC6445G Udisk No files found

Hi,

I’m just setting up my DIY 50W Laser cutter with a Ruida RDC6445G controller but whatever usb disk I put in it says no files found?

I’m using a Mac so it could be the formatting of the disk i tried mac native, FAT and ExFat but it doesn’t seem to make any difference.

Am I doing something wrong?

Thanks in advance!

Peter

I’m not certain of the format used, but probably FAT32 or FAT. It only sees files in the root folder, and all filenames have to be 8.3 with no spaces, with the .RD extension.

Just tried it with FAT32 and a test.rd file but it keeps saying “No files”, Also tried to connect to the device via USB but it shows an empty “Device Discovery Wizard” screen?

Any ideas?

For the USB device, make sure you’re plugging the drive into the correct USB port on the Ruida. There are two - one for the PC, and one labeled “UDisk” - you want the 2nd one.

If you’re connecting to a Mac, you might need to do a full reboot of your system. The FTDI drivers (for the chip used for USB connectivity in the Ruida) are known to compete with the Mac virtual serial port drivers, and sometimes causes ports to get locked out.

For all of those with similar issues, I finally found out what the problem was to my issue.

It was the way the usb-sticks are formatted. I thought I was doing it correctly but the Ruida controller wasn’t able to read them.

You can format your disk two (sort of) ways on a mac.

One (the wrong way):


You can format the partition which in my case always worked on any 3d-printer or CNC machine but for some reason the Ruida wasn’t able to read the files on it.

Second (The right way):


You must select the Disk itself not the partition on it. Make sure you select the Scheme “Master Boot Record”.

That did it for me!

Hopes it helps someone

Peter

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.