Some kind of bug with splines

Hello Friends.

I’ve been using Lightburn for a few months now and it works well for me. But recently I noticed a weird problem where, strange anomalies or added “zig-zags” appear in some of my lines imported from dxf files. More precisely, these problems appear in lines that were originally drawn as splines, but seem to occur more often in splines that have been offset. I’ve attached an image of what I’m trying to describe. Instead of a smooth spline as originally drawn in my CAD program (Draftisght), when imported into Lightburn these anomalies appear. Must have something to do with settings in the conversion process. I haven’t experienced this originally, but started to notice it about a month ago or so. I don’t remember if I’ve changed any settings in the Settings menu (image also attached). I believe the version of Lightburn I have now is 0.8.07.

Thanks if you can help.


When you say, “splines that have been offset” - where are you doing the offsetting? In LightBurn, or in Draftsight? Have you tried importing one of these DXF files into anything else to see if the anomalies show up in other software too?

Hello Oz.

Thank you for your reply. I think I have it figured out, but I’ll answer your question first…

I am doing the offsetting in Draftsight. I draw a spline in Draftsight. Those get the anomalies when importing into Lightburn. But what really gets the anomalies are new splines that have been offset from the original spline - also originally drawn in Draftsight.

Okay, how I think I fixed it is, I increased the CURVE TOLERANCE in the Settings menu. I had it set at 0.050 I believe. When I bumped it up to about 0.200 these anomalies disappeared. I wonder what are typical values in the rest of the options in the Settings menu. I think I have them pretty messed up, but I fixed this problem…



Just out of curiosity why you don’t want to do the free upgrade to your software version? The release notes show multiple references to fixes/improvements for the importing functions.

That setting only controls the data sent to the laser (at least, that’s all it’s supposed to affect - I’ll look to make sure). Why are your shapes 70 meters off to the right of the machine? If you could email one of the original files with the wobbles in it to developer at lightburnsoftware dot com I’d be curious to have a look.

Hi Doug.

I did not “not want” to upgrade the software. I just hadn’t checked for updates. Now that I have found an update I’ve installed - thanks!

Hi Oz.

I’ve downloaded the latest version of LightBurn. Now the “wobbles” no longer appear in lines drawn as splines (in dwg and dxf) after importing into the new version of Lightburn. Even after I’ve reduced the Curve Tolerance to 0.050. So, I guess the problem has been solved so well that I can’t replicate it even if I try. If I come across this again I’ll re post.

…And oh, I have “Cut Selected Graphics” and “Use Selected Origin” selected so my drawings don’t need to be positioned on the cutting bed.

Thank you.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.