Some move buttons don't work

I have just installed a Jtech 7W laser on my X-Carve CNC.

I’m having problems with LightBurn not being able to move the axes very well when using the buttons on the move dialog.

The CNC is working fine. Under the UGS Platform, the gantry moves as normal using the original GRBL settings.

While using LightBurn I have changed the GRBL settings for the laser as described in the JTech website.

Using LighBurn, the machine homes OK, but after homing the axes either don’t move or move once. For example, I can move the Y-Axis towards home, but not away (left and right arrows respectively). The Z-axis does not move at all using the buttons, and I do have Allow Z movement set in the LB configuration.

Fun fact: using the Frame button does make the CNC work delineating the engraving area as expected. Also using the console to send gcode move commands works for all axes in all directions as expected.

I was able to make a simple engraving positioning the starting point manually. So it seems that the problem is solely in the use of the arrow keys on the “Move” dialog.

If you have any ideas or have seen the problem before, please let me know.

Running latest LightBurn 0.9.09 on Windows 10 and GRBL 1.1f.

Thank you.

What is the value of your $10 setting? It should be zero for use with the origin change in LightBurn. I think that’s the one setting they missed on the J-Tech setup guide.

Hi Oz, thanks for the quick reply.

The weird thing about this problem is that some of the keys do work as expected, Y + and _ work fine as does X -. Z does not make the gantry go up or down at all, so it makes it really hard to focus the laser.
Also the framing works, and using the “locate” too on the toolbar also moves the gantry to the correct place.

Jay had warned me about $10 missing from their instructions, so I do have it setup to zero as you can see below.

Thank you very much for helping out. If there is anything else you need from me please let me know. Maybe there are some logs that show the commands sent from the GUI, or a way to turn tracing/logging on…

EDIT: I just noticed that Hard Limits are turned on, I usually only have soft limits enabled. I will turn that off and try again in a little while, I’ll let you know.

Here are all my GRBL settings:

$0 = 10 (Step pulse time, microseconds)
$1 = 255 (Step idle delay, milliseconds)
$2 = 0 (Step pulse invert, mask)
$3 = 2 (Step direction invert, mask)
$4 = 0 (Invert step enable pin, boolean)
$5 = 0 (Invert limit pins, boolean)
$6 = 0 (Invert probe pin, boolean)
$10 = 0 (Status report options, mask)
$11 = 0.020 (Junction deviation, millimeters)
$12 = 0.002 (Arc tolerance, millimeters)
$13 = 0 (Report in inches, boolean)
$20 = 1 (Soft limits enable, boolean)
$21 = 1 (Hard limits enable, boolean)
$22 = 1 (Homing cycle enable, boolean)
$23 = 3 (Homing direction invert, mask)
$24 = 25.000 (Homing locate feed rate, mm/min)
$25 = 750.000 (Homing search seek rate, mm/min)
$26 = 250 (Homing switch debounce delay, milliseconds)
$27 = 1.000 (Homing switch pull-off distance, millimeters)
$30 = 1000 (Maximum spindle speed, RPM)
$31 = 0 (Minimum spindle speed, RPM)
$32 = 1 (Laser-mode enable, boolean)
$100 = 40.072 (X-axis travel resolution, step/mm)
$101 = 40.000 (Y-axis travel resolution, step/mm)
$102 = 100.136 (Z-axis travel resolution, step/mm)
$110 = 8000.000 (X-axis maximum rate, mm/min)
$111 = 8000.000 (Y-axis maximum rate, mm/min)
$112 = 2000.000 (Z-axis maximum rate, mm/min)
$120 = 500.000 (X-axis acceleration, mm/sec^2)
$121 = 500.000 (Y-axis acceleration, mm/sec^2)
$122 = 300.000 (Z-axis acceleration, mm/sec^2)
$130 = 790.000 (X-axis maximum travel, millimeters)
$131 = 800.000 (Y-axis maximum travel, millimeters)
$132 = 150.000 (Z-axis maximum travel, millimeters)


The way jogging is done was recently changed to allow for continuous jogging support, and the new jog code respects machine limits and isn’t just sending relative moves any more. It’s possible something in the way this works, or a difference in how your controller is reporting position, has broken it.

Can you type ? in the console and press enter, and copy the response from your machine here? I have one idea as to the cause, and this would confirm it.

Hi Oz.

Here is the results of ? on the console:





I was reading the Forum and ran into one entry where they talk about turning off Continuous Jogging. I just did and now I seem to be able to move all axis. I haven’t done any extensive testing yet, but that seems to have fixed it. I also turned on “Relative Z moves only” not sure if that had anything to do with the previous inability to move the Z axis. I think it was the “Continuous Jogging” setting that did the trick.

Thanks again for your help even during the Holidays. Also let me know if you see anything in the ? printout above, maybe you see something else wrong.

All the best.


Continuous jogging was going to be the next thing to try, but since you said you had just installed, and we made it off by default, I didn’t think you’d have that enabled. Happy to hear that’s all it was.

I guess that when I was trying all the other stuff, before I reached out here, I might have turned it on by mistake.

Anyhow, I will be purchasing a license in the near future before the trial expires.

I appreciate your help.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.