Some Observations and Questions about ver 9.20

I posted a new topic 4 days ago concerning use of the keypad (using keypad with unexpected results) which I received no replies. I should also say that I very much like Lightburn and I have gained much information from others posts.

I have solved much of these problems after much trial an error and actually reading the getting started topics again.

I have two cnc’s a millright mega V and a 3018. At the moment I’m getting this information by testing with the 3018 which is running Grbl 1.1f and no limit switches. I am using a computer running Windows 10 64 bit and connecting via USB 2.0. Also I have $J Jogging ON and DTR off.

Maybe this will help someone else.

First I believe my biggest problems are related to my apparent wrong assumption that if I wanted to use imperial measurement I should switch $13 to True (report in inches) in Lightburn. Switching $13 to True in Lightburn created numerous problems with jogging and position readings. (See my previous post for some of these problems) This occurs weather or not you have the other settings in Lightburn set to in or mm. This leads me to my first question…. If Lightburn requires that $13=0 (false) or that it reports in mm to work correctly why not automatically change it to False when Lightburn opens. It could be reset to its original setting when Lightburn closes or at least have a warning that changing this setting to True may cause problems with Lightburn.

Some observations/questions:

On my screen in the Move window the im is cut off by the border on the speed and z-speed so that you only see in/m after these two fields.

If you change from mm to in on main screen (next to rotate) the Units /grids in settings is changed to Inches/mm/min even if it was set to Inches/ min before.

When connecting the Ready under Laser (in laser window) will show ready if it connects to any com port even if the laser/cnc controller is not connected. It would make more sense to me if it only showed ready after connecting to the controller successfully.

When jogging with the mouse no problems but if I use the keypad I get no movement if I Hold the Shift key. The Ctrl and Alt keys work as expected. This occurs with Continuous Jog ON or OFF.

With Continuous Jog ON the Get Position values update dynamically after each move (mouse or keypad) but with Continuous Jog OFF the values are only dynamically updated when using the keypad. If I move the laser with the mouse I have to click Get Position to update the values.

Someone please correct me if you find any of this is incorrect.

The $ settings are firmware and not LightBurn settings, so this may be part of the issue.

LightBurn is software that talks to your motion control board. Your motion control board has firmware installed, known as Grbl, which has settings to tell your laser where and how it moves and behaves. These settings start with "". These settings are not LightBurn settings, they are your firmware settings. These firmware settings need to be correctly configured to match your machine for any software to perform as expected, including LightBurn.

While LightBurn does provide tools to help ease in the viewing and adjustment of your motion controller settings, we do not change any of these settings without direct user interaction.

Please show us a screenshot (no cell phone pictures - hard to see) of what you are seeing?

move windowJPG

Tight to the edge, yes, but this is not cut off that I see. In LightBurn, this is the way we represent inch per minute, “in” (inch) “/” (per) “m” (minute), in/m = inch per minute.

image

Ok…but everywhere else I can find it is min.settings gridunits
Any while your at (I know you have so much free time)::smiley:
How about moving the arrow keys over , place the home some where else , and leave the A and Z keys
separated. Much less chance of hitting the wrong key when trying to align the laser.

This is a known issue, reproducible here, and has been reported to the Dev Team. :slight_smile: Thank you for reporting this.

+1 on removing Home button from this configuration. Have inadvertently hit it many times while attempting to jog.

Rick,
Could you please respond to the last 3 paragraphs?

If you are asking about rearranging the UI, noted. Thank you. :slight_smile:

No, I was asking about the last 3 paragraphs of the original post. Especially Using Shift with the keypad. I assumed my UI request would put on the list with the hundred others you probably get but I still think it would be a good idea. Thanks

When connecting the Ready under Laser (in laser window) will show ready if it connects to any com port even if the laser/cnc controller is not connected. It would make more sense to me if it only showed ready after connecting to the controller successfully.

When jogging with the mouse no problems but if I use the keypad I get no movement if I Hold the Shift key. The Ctrl and Alt keys work as expected. This occurs with Continuous Jog ON or OFF.

With Continuous Jog ON the Get Position values update dynamically after each move (mouse or keypad) but with Continuous Jog OFF the values are only dynamically updated when using the keypad. If I move the laser with the mouse I have to click Get Position to update the values.

Because EEPROM / flash memory has a limited number of writes, after which it simply fails and requires replacement. We’re not in the business of bricking peoples controllers. If I forcibly overwrote that setting on startup, and reset it on exit, it wouldn’t take terribly long before you had to replace it.

This is known. Most users exchange cut speed settings in mm. I have it on my todo list to make it remember both your distance and velocity units, and when you flip to another metric, have it remember them so it can flip back to what you had before.

Can you show a picture of this?

The console for GCode controllers is the only way to know for sure that it’s connected. The reasons are complicated.

I think this is fixed for the next release, but I’ll double check.

Thanks for the reply OZ.
The picture was posted previously in the post.
What about
When jogging with the mouse no problems but if I use the keypad I get no movement if I Hold the Shift key. The Ctrl and Alt keys work as expected. This occurs with Continuous Jog ON or OFF.

True, but in space constrained windows it gets shortened to /s or /m instead of /sec or /min.

This looks fine in English, but in German, Polish, and a couple of the other languages, or on systems where the users have increased their font scaling, it gets really squeezed together:

image

I’ll have to look.

The problem is that the number pad keys, when num-lock is enabled, are emulating other keys (the numbers, pgup, pgdn, home, end, etc). When you press Shift + one of those keys, it sends a different key code, and some of those are mapped to other functions (like PgUp and PgDn) so it’s not trivial to handle them another way. I can see if there’s a way for me to detect the actual physical numpad keys and intercept those.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.