Some Suggestions for Linux (Installer reporting, and Interface Size (no Maximise available))

Thanks for producing a Linux version of your software, I was able to, with a little fiddling working out which GRBL device I needed to use to get my NEJE device working.
However, I have a couple of suggestions.
When running the .run binary to install the software, it would be great if there was some kind of message to inform user’s that the software has indeed been installed, and not just exited out. This led me to believe initially that there was an issue installing or running the software, and I almost gave up. If I hadn’t inadvertently noticed the icon present in the Graphics Folder in the Menu, I would have thought the software doesn’t work on my machine, or I was missing some dependencies.
Other than that, the software opened just fine, which brings me to my second suggestion.
Whomever, has coded the interface needs to realise that other people’s screens may not be the same size as there’s, as the bottom of the interface is cut off, and can’t be resized, or maximised. There’s isn’t even an option to maximise in the window toolbar. This should be considered for a future update, as reading some posts on your forums to see if there was a solution, other than using a higher resolution which isn’t always possible, that a lot of your users will be using a Laptop, as am I. I have yet to try the software on a Desktop Linux machine to see if this is an issue, but the same considerations should be made.
Please do look into these, as a lot more people are moving to using Linux, and the simple fact that you are providing a Linux version is fantastic, and appreciated.

I have no issues with the actual installation of Lightburn on two desktop computers with Ubuntu 20.04. My screens are quite large and the screen resolution is so high that I actually have to drag the window with Lightburn all the way to the edge.
But in return, neither of the two computers will connect with my Mini-Gerbil over usb. It’s very annoying and frustrating and I do not have enough knowledge to experiment or program in Linux.
If there is anyone who bothers to help me with that I will be very happy.
Regards
Bernd

The .run installer is intended to be invoked from the command line where it will give you status of the installation.

What resolution are you using? There’s simply a minimum resolution into which we can fit everything needed.

HI Adam,
Sorry I meant to get back to you sooner, thanks for responding.

I understand the intention to run the installer in Terminal, but I think a lot of new users to Linux would try to install via clicking on the downloaded file and not attempt to run the installer via Terminal, just thinking how a new user would approach this.

My Laptop’s resolution is 1366x768. I do understand about fitting all the information into a limited space, I think it just need to be kept in mind that most users would be using the Software on a Laptop, I have yet to try the Software on my desktop.

So I understand this but the issue is not the resolution it is that there is no option to make the screen smaller. It is a set size. Most other programs you have the option to choose if you want it full screen or smaller. This only allows it to be full screen. The layer colors are off the bottom of the screen and there is no way to use them.

I agree with Dennis that this is a program issue that was an overlook. I am not working from my Linux machine or I would share a screen shot. All other programs I use on Linux have this option so I do not see why it cannot be an option on LightBurn

I have used Lighburn a bit more on my Linux machine.
I have found that when I connect the computer to a larger screen the option to minimize returns. With a large screen it works ok but on the laptop the layer options are unusable.

I have the software on a Windows machine as well and there I can minimize it and have all the options. I still feel that if it is an option on windows it should be as well on Linux

thanks

What linux distro, version, and what window manager (Gnome, KDE, Unity, etc) are you using?
What you are talking about with it not letting you change the size of the window really seems more of a window manager (WM) thing to me. In fact, on linux we really have no control over if, for example, the minimize option is available. We can tell it that we want that option but ultimately it’s up to the WM to manage that. And that can get pretty weird on some versions of linux or specific WMs.
And I admit that a lot of this is likely because of the resolution you are running at - LightBurn’s UI is very dense and we’ve done what we can to minimize that. But there’s a limit. You may also have some sort of UI scaling applied in your WM which would make the problem even worse.

One thing you could try is the “Toolbar Icon Size” option in settings. Just drop that all the way to the left and see if it helps.

Thanks for your help.

I am very new to Linux, so I accept that you have done your best.

I found it confusing that the minimize was available on a large remote screen but not the laptop screen. I will try you suggestion. I have tried other resolutions on the screen but it distorts it so that it is not usable. I will also check with my linux IT support guy to see if he as any suggestions.

I can use a large screen in the office but I cannot carry the screen with me out to the shop where the machine is.

Thanks for your help. I am glad it is available as an option for Linux.
Jeff

I use Linux Mint and I have all 3 buttons to minimize, resize, or close the window on a 1920 x 1080 screen.
However, if I try to drag a corner of the window to resize it the SMALLEST it will go appears to be 963w x 877h. It won’t drag smaller than that.

So perhaps if your screen height is shorter than 877 the resize option might go away?

This isn’t true - There is no option to make the screen smaller once you hit the minimum size for your window layout.

With the default window layout, my PC’s minimum window size is 878 x 829:

If I change the layout so the Laser window and Cuts/Layers are tabbed together, the minimum size is now 878x534:

That’s without adjusting icon or font sizes. If I was to dock the palette bar to the left, next to the tools, the minimum height goes down even more. The issue is not that the display can’t be resized, but that you’re simply trying to show more than will fit on your screen.

My resize options do go way on the smaller screen.

I have found that by removing thing the laser window though I can make is smaller so that the cut layer options are there.

Thanks to all of you for your help

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.