Speed and Power settings not being saved in .nc file [AtomStack x20 Pro]

I’ve just started playing around with Lightburn and my new Atomstack X20 Pro.
I created a design to engrave, and set the speed and power in the Cuts/Layer tab, and then saved the .nc file. I transfer the file to a thumb drive (with a TF card) and insert it’s TF card into the Atomstak.
However, when I open the file and start the engraving, the little hand-held terminal/control says it’s using 100% Power and Speed.
Is there something else I need to do to get these settings to apply?
Is there a way to see if they are in the g-code (or add it manually)?
===[ Greg ]===

It’s likely that whatever the configured speed is in gcode will show as 100%. The percentage may be meant to show changes from base (100%) using on-screen overrides.

Test that the speeds for engraving are indeed changing by making one with very slow speed and one with very high speed. The difference should be apparent.

Thanks! I looked again and the hand-held says 100, 100… not 100% 100%. I looked at the g-code and it does have “S” parameters for power settings. I picked 50% in Lightburn, and the g-code shows S500 (which I’m guessing is 50.0% power).
I do like your idea for a test… I’ll do a very slow and low, and then a very high and fast to see if it’s actually using what’s in the g-code, even if the handheld always reads 100, 100.
Thanks again!!

You can get much more control of your laser by connecting the machine directly to lightburn via USB. Is there any reason you are using TF card rather than direct connection?

Well… I have a desktop PC in my basement, and the laser is in the garage. Unfortunately, I can’t get the laser’s wifi signal in the basement, so I have to go back and forth with the TF card :roll_eyes:
I’d love to get a cheap-o laptop, or even figure out how to get the wifi signal to reach my desktop.

I have an old laptop that I use in my garage just for the laser. I edit on my indoor laptop and save to Google Drive (any cloud storage works). In my garage, I simply load the file from the cloud and laser away!

OK, so, the speed and power settings are being used from the g-code. I’m just ignoring the 100/100 on the hand-held.
And, I’m having a heck of a time aligning my material to where ever the Atomstack decides to start.
My Onefinity CNC knows my material size and uses whatever corner you choose as 0,0. I’d like to do that with this, but I’m guessing that’s where the laptop will come in. More precise control, ya!?
Thanks all!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.