Speed does not go at entered velocity


(Hugh Lyman) #1

I have an Eleksmaker Board with Grbl-M3, 15W diode laser, 10V power supply. I set the speed to 200mm/sec. The image is 70mm wide plus 10mm over scan.
It takes 3 sec to travel the 80mm which is like 27mm/sec. What am I missing?


(Oz) #2

The settings in the controller itself are likely limiting you to far lower than 200 mm/sec, and if not, if you’re trying to engrave an image, the 8-bit controller probably can’t process GCode fast enough to sustain that rate.

Go to Edit > Machine Settings and check your X and Y axis max rate (in mm/min) to see what they’re set to. 200 mm/sec would be 12,000 mm/min.


(Hugh Lyman) #3

Thanks, What controller can give me a higher variable speed and better variable power control?


(Oz) #4

The Awesome Tech Gerbil controller or Cohesion3D LaserBoard are both 32 bit boards. The Gerbil board runs GRBL, and the C3D board will run Smoothieware or GRBL, and both are capable of significantly faster GCode processing than an 8 bit board. Either of those I’d recommend.


(Hugh Lyman) #5

OK, I checked and changed the settings to mm/min. I started printing the Power Speed test pattern and it started just fine, printing the 1st layer of text, then the the 1st layer of patterns which is 600mm/min and 100 to 10% power.
Printed the 2nd layer at 1200mm/min just fine and started the 3rd layer and machine stopped. Searching everything to determine the problem and did not know what stopped the machine. Tried it several times and now it only runs for a few second and turns off. Loaded up a image into T2Laser software and it printed fine. Load up the same image in Lightburn and it printed just fine So I assume the problem is with Lightburn such as the vaiable speed and power setting within each layer. Your comments would be appreciated.
Hugh Lyman


(Oz) #6

What does the console say when it stops? It’s not uncommon for these machines to have intermittent grounding or electrical noise issues.


(Hugh Lyman) #7

Trying again this morning. Console shows “ok”
Attached is a screenshot. And here is what I just tried.

  1. Load Power Speed Test file
  2. Frame checks OK
  3. Start
  4. Note “Cutout out of bounds” click yes
  5. Laser moves to start position and laser turns on.
  6. Laser axis X & Y do not move
  7. Laser stays on and burns a hole in board.
  8. Turn machine off to stop laser light
  9. Turn machine on and laser is still on.
  10. Jog left and an laser turns off.
  11. Tried again without success.

Note I have version 9.02 though I now see version 9.03 is out. How do I get it?


(Hugh Lyman) #8

I log off and rebooted the Lightburn software and I notice that the Console showed “Ok” and below that an “error 5”.
What is error 5 and is this the problem.
I loaded an image bmp file and it did not print same as the power speed test file.
I loaded the same bmp file into T2Laser and it printed perfect.


(Oz) #9

“Error 5” is a homing cycle failure - you don’t have homing or limit switches enabled on your controller, but you have LightBurn set to home on startup.

Can you post which version of GRBL you’re running? It will say when it first connects, something like Grbl 1.1f [press ? for help. And then post the controller settings. Type $$ in the console and press enter, then copy and paste all the text it outputs here.

“I loaded an image bmp file and it did not print same as the power speed test file.”

In what way? Unless it was an image of the power speed test file I would not expect it to look the same, so I don’t understand what you mean.

To get the new version, go to Help > Check for Updates to download it. Close LightBurn and run the downloaded file when the download completes.


(Hugh Lyman) #10

Opened machine setting and made some changes so error 5 is fixed. I also changed the Max x and y distances and the power max settings.
Now when I boot up error 5 is gone and the laser flashes but the axis x & y do not work. I tried to reopen machine settings and a get “Comunication with controller failed”.
I have designed 6 models of my filament extruder, 4 3d printers, 2 CNC routers. Own and operate a FSLaser and now I can’t even make a simple DIY engraver work. I will order the new controller you suggested, and then get back with you. You have been great to help me.


(Rick James) #11

When time is invested to provide you with diagnostic steps/questions, please provide the requested information. We ask questions to try and help you maximize the use and satisfaction you find with LightBurn.

You mention that you continue to make changes, you don’t identify what you changed, (changed from what to what) yet we still have no understanding of what you are really working with. Buying a different controller might help with the throughput, but it won’t tell us what you are using when asked. This makes it almost impossible to provide you with a reasonable and appropriate answers.


(Oz) #12

Don’t go into the machine settings, just type the command shown above and copy/paste the output. It’s possible the controller you have is a really old version of GRBL where the commands or strings don’t conform to the format LightBurn is looking for, but if you don’t post the info we need to figure that out it makes it very hard to help you.


(Rick James) #13

image