Squiggly lines only with line engraving not fill

Got a fun one I’m up against. 60w omtech c02 with a ruida controller. One of my units decided to start producing squiggly lines while engraving only. 100mm/sec @ 4ma line engravings. Started with the simple pwm switch in machine settings, no change. went through the alignment process, everything is happy and spot on. Then I moved onto if anything was loose mechanically. Working on a lot of laser units I have a lot of spare parts, so I swapped out all the mirrors and lens. Retightened everything, rechecked alignment. Checked the linear rail system, re gressed, belt system, & mirrors/assembly for any free play. Belts seemed like they could use some tightening so I tightened up box axis a hair. Recheck with no change. Grabbed the machine settings from my second laser which is happy and loaded into the problem child, no change there. Swapped usb cables, also sent the file directly to the controller with no change.

Was thinking if there was a mechanical issue there would also be squiggly lines during fill engraving as well. Ran a fill engraving at 250mm/sec @ 5ma with a perfect engrave. No weird lines. So now it’s got me thinking something internal like the controller is maybe causing the issue? This one has me stumped today. Any thoughts what would cause the lines to be squiggly only with a line engrave and not a fill? I’ve tried a regular line engrave at 40mm/sec with the same squiggly issue. Appreciate any guidance

I also have a similar problem when cutting above 25mm/s. I received a reply that trying to send the file to the laser via RDworks helped some. it didn’t help me

Thought about seeing if there’s an update from ruida, but what’s strange is this machine has been working flawlessly for a solid year with any issues. I wouldn’t think it’s a firmware issue if it just started happening.

That would seem some type of machanical issue. I would update any firmware unless

  1. fix a known issue
  2. am going to replace controller anyway…

I don’t know what is different speeds?


Hi, I found something similar on another forum. it is worth reading

IMHO, looks like mechanical excitation by steppers. Something got into mechanical resonance.
Interesting to know if this was slow onset or sudden? Any coincidence with some parts replacement?

Assuming you did check for any play in the system and there is none:

  • Motion parameters, first of all acceleration, is too aggressive. Set lower. Times lower, not %%.

  • Belts are or got soft. Was any replaced? How are they tensioned?

  • Any other parts or assemblies being changed? Anything that can affect stiffness of the machine? Any part changed weight? Different assemblies, screws, brackets, etc…?

  • Was steppers re-tuned or current settings changed? Over-driving steppers may produce excessive jerk on step that may excite mechanical resonances.

Got this baby almost all worked out! After talking to a few experts I was advised to pick up some new linear bearing blocks considering it was happening along the y axis. Disassembled mine and cleaned/re lubricated, then reassembled. Already 1000x better. But got some new ones on the way to completely eliminate the problem.

Here’s some pics to confirm it was along the y axis

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.