Start position?

Running GRBL 1.1f
I have noticed at times the green square or start position is outside of my SET engraving size. Where is the setting to control where this green square starts at? I have had it outside of my grid (work area) and the red (Laser) at the bottom left of the grid. It offset my job by the distance between them.Start

The red dot is your machine origin. This page should help: https://github.com/LightBurnSoftware/Documentation/blob/master/CoordinatesOrigin.md

Oz,
Thanks, I’ll have a look, although I don’t remember changing it.

That was it, although I don’t remember changing it. THANK YOU

I’m having an issue with this as well. I get the laser to position and select User Origin. I hit the frame button and it appears to framing in the proper position. When I hit Start it’s moving the laser to some random area and moving the Z axis way up.

How do I stop this?

From the documentation page posted above^^^

User Origin works almost exactly the same as Current Position, except that the starting location is “programmable”. Some lasers have an “Origin” button on them (like Ruida controllers). GCode based systems use the “Set Origin” button in LightBurn to do the same thing. You jog your laser to the position you want your job to start from, hit the “Set Origin” button, and then you’re free to move the laser around again. If you specify “User Origin” as the “Start From” value, the laser will move back to that programmed location and start the cut from there.”

Excuse me, I meant I’m using the Current Position option. It’s just giving me a behavior I wouldn’t expect.

I am jogging the machine into position, hitting Current Position, and then it is doing what I referenced above.

Honestly, I’m about done with the software. It’s been a collosal waste of time and productivity

If it’s moving the Z axis when you hit Start you should enable “Relative Z moves only” in the device settings, or set your “Material (mm)” setting on the main page to the Z value you wish to use.

The upcoming release fixes an issue with the framing in User Origin mode for GCode machines.

I suspect this is a simple misunderstanding between how you think it should work vs how it actually works. The “current position” setting does run from wherever you set the laser head, but runs the job from the “green dot” origin point shown in the edit window.

The Z setting change I mentioned should fix the Z move. For the other behavior, check the Coordinates and Origin page I linked above just to make sure that what you’re seeing isn’t just “how it’s supposed to work”. If it’s a genuine bug I will fix it, but new users often have a bit of difficulty with the job origin settings.