Starting Off - Complete Newbie

Hi Everyone im new to LB & Laser Engraving, im having a few issues getting started. Im using:
KKmoon Controller GRBL
Nema 17 - Model No is: 17HS1352-P41
Laser using PWM

I cant get my $$ settings right to move my axis X & Y.
I am using 8MM Threat CNC Rod

Could anybody help me at all please, these are my current settings:
$$
$0=10
$1=25
$2=0
$3=10
$4=0
$5=0
$6=0
$10=1
$11=0.010
$12=0.002
$13=0
$20=0
$21=0
$22=0
$23=0
$24=25.000
$25=500.000
$26=250
$27=1.000
$30=1000
$31=0
$32=1
$100=200.000
$101=200.000
$102=0.000
$110=500.000
$111=500.000
$112=0.000
$120=100.000
$121=100.000
$122=0.000
$130=200.000
$131=400.000
$132=0.000

$100 and $101 are the “steps per mm” values in GRBL. If you’re using threaded rod, chances are those settings are too low.

For example, if it takes 1 full rotation of the rod to move the head 1mm (I’m guessing), then you would need 200 full motor steps to move 1mm. You would need to multiply that by whatever microstepping values your motor controllers are using. If they are set to 8x microsteps, you need 8 x 200, or 1600 steps per mm.

Your $110 and $111 settings are currently 500mm/minute, which is also very low. You’ll need to increase that if you want any reasonable amount of performance. Read through the GRBL docs here to learn what the various values mean: https://github.com/gnea/grbl/wiki/Grbl-v1.1-Configuration

I managed to sort this out, My next issue is HOMING

I am only using X & Y axis not Z as its a laser.
How can i disable Z by the Console as im not using a arduino its a KKmoon Controller.

I’m honestly not sure. I don’t know if you can disable Z homing through configuration alone, as mentions of it online suggest compiling out the Z homing: https://github.com/grbl/grbl/issues/1271