Starting position-1





Target buffer size found

[MSG:Using machine:MKS DLC32]

[MSG:No Wifi]




Homing cycle is not enabled in your Grbl settings.

[MSG:Start mDNS with hostname:http://mks_grbl.local/]

[MSG:HTTP Started]

[MSG:TELNET Started 8080]

Starting stream

[MSG:Program End]

Stream completed in 0:00

Starting stream

[MSG:Program End]

Stream completed in 0:05



Starting stream
why does my starting position indicate way off the grid when my starting project begin at the lower left corner? and when it starts the first burn, it wants to start way over beyond the grid?

How are you homing it?

I manually move the laser to lower left corner. When I do get it to do project it automatically sends it to the lower left corner when finished.

I have had to select all of my project in order for it to do all of my 3 inch circle cut outs. It will do the job sometimes and be aligned for the most part but when I try to pick up the following day… the cut outs are not the same. The position is off even if I leave my “stencil” in the same position. I have to find my laser all over again and make another stencil from scratch each time. It takes a good hunk of my time to start over every time.

For positioning repeatability, Homing with switches is almost mandatory. You cannot “Home” the machine without switches and GRBL parameter $22=1. clicking the Home button is why you are getting the Alarm 5 message.

You are working with Origin, not Home. Without Homing, Origin is where the laser head is sitting when you power up the machine. It is easy to be off a mm or more if moving the head to the front-left corner.

Are you calling this your “starting” position?
MPos = machine position
WCO = work coordinates
Tjhis link has a lot of info about coordinate systems. Scroll back up for some good descriptions.

Are you saying that in my console window I should type in the command $22=1? so GRBL knows that’s were I want to start without limit switches?

|### Eric Tyler|12:55 PM (0 minutes ago)||

| — | — | — |
|to Mike


I think I answered my question…I went to the GRBL Configuration page and typed the G92 X0 Y0. We will see how this goes. I would hate to have to do this everytime I start a new project. But if I save it as a Micro then all I have to do is click the macro that I saved it to and Lightburn should remember what it is no matter what my new project is correct?

NO, that tells the controller you have Home switches, and to look for them when commanded to execute the Home cycle.

You told the controller to use Incremental positioning (every move is computed from the existing current position). I recommend you use Absolute positioning (every move is computed from the 0,0 Home position) for now. Select Absolute Coords in the Laser Window and forget the macro.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.