Stepper enable question

it’s just a question, not really important.

In the CNC environment I was used to the stepper motors locking up when the program was stopped, but that is not the case with the laser.

Is that intended or do I have a wiring error.

It’s likely working as configured.

Check GRBL config for $1. The value represents time in milliseconds of motor idle before power is disengaged. You can keep on permanently with $1=255.

Here’s an excerpt of GRBL documentation on this:

$1 - Step idle delay, milliseconds

Every time your steppers complete a motion and come to a stop, Grbl will delay disabling the steppers by this value. OR, you can always keep your axes enabled (powered so as to hold position) by setting this value to the maximum 255 milliseconds. Again, just to repeat, you can keep all axes always enabled by setting $1=255.

The stepper idle lock time is the time length Grbl will keep the steppers locked before disabling. Depending on the system, you can set this to zero and disable it. On others, you may need 25-50 milliseconds to make sure your axes come to a complete stop before disabling. This is to help account for machine motors that do not like to be left on for long periods of time without doing something. Also, keep in mind that some stepper drivers don’t remember which micro step they stopped on, so when you re-enable, you may witness some ‘lost’ steps due to this. In this case, just keep your steppers enabled via $1=255.

thanks @berainlb

i understand it all

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.