Stepper stop and run in the firing points when engraving an image instead of continuos run

Im using GRBL in ESP32 with FluidNC firmware.
Everything works fine but while engraving,

In other laser engraving videos, the X axis run continuously end to end and only laser seems to be triggered. but in my case at each point to be burnt, the stepper stop and fires.

Please upload the current version of config.h for your FluidNC firmware, a small LightBurn project that demonstrates this behavior (the smaller the better), and the GCode generated by LightBurn for the small project (click File - click Save GCode).

The files should upload by using drag and drop (into the reply box) or with the Upload button (up arrow - rectangle box icon) in the middle of the top of the reply editor. If the permissions interfere, please change the file extension to .txt and retry.

Spindle drivers and carving programs may come to a full stop after traversing to begin a plunge operation. If you imported GCode from another generator it may have saved z moves which could appear as full stops as your controller counts them out.


Thanks for the reply john.
In Light Burn, we have 3 options of GRBL.
Among them, I was trying, GRBL-M3 (1.1e or earlier) was not having the functionality of Dynamic Laser Power Mode.

Now i tried with GRBL (1.1f or later). it works fine now.
below links are the ones i refered.

I’m glad you’ve got it sorted.

If you used one of the standard config files offered by FluidNC for your controller I’d be grateful if you’d share a link.


Hi John,
Ofcourse I tried using the standard config file for FluidNC but in that I need some additional configurations related to homing and laser functionality.
So I discussed with FluidNC developers in discord and got them sorted from fluidNC side aswel.

here you can find the standard configs.

Among the list, I took [3axis_v4.yaml] file as reference and modified it to the below.
Laserx.txt (2.0 KB)

Just a note config files are always .yaml so you gona use my config, please rename the extension to .yaml instead of .txt


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.