Steps Per Rotation Has No Effect On Image Width

Hooked up my rotary today and everything looks great, but my image is the wrong size. I tried engraving an 80mm wide box, but it only comes out 65mm. Rotary is Enabled, Rotary Type is set to Roller, Roller Diameter is set to 25mm, and I tried setting “Steps Per Rotation” to 2500, 3000, 5000, and 8000. The width is always 65mm. Height is good. Circle Pulse from RDWorks pulls into LightBurn Steps Per Rotation fine.

All the wiring appears to be correct. Y-Axis works as expected. LightBurn sees the controller as a Ruida 644XG. Controller is a Ruida clone.

Any suggestions where to look next?

Controller reset?! My Awc708c need every time a push in the reset button.

I have reset the machine many times during testing. At what point in the process are you pushing the reset button?

What does RDWorks report as the controller type? Any idea how old the controller is, or what firmware it’s running?

When using a USB cable, LightWorks sees the controller as a Ruida 644XG - USB. I believe the controller is a recent model. It is a Ryxon KT332N running firmware RX-V23.01.04. The software that shipped with it was RDWorks version 8.01.48. I have done more testing and I can replicate the issue in RDWorks. I had a remote session with Randy from HM Laser and he says everything looks good. I have a video describing the issue if you PM me.

Controller Web Site:

If you use their provided software, does it have rotary setup in the user tab, including steps per rotation? Some hardware just does rotary by scaling the Y axis, and doesn’t have the built-in hardware toggle to switch between them.

Interestingly, the software that came on the USB drive with the laser was RDWorks (and it is one minor point revision newer than what Ruida has available on their web site). While the Ryxon web site has RXWorks. I was getting virus warnings during install, but I got it on RDWorks as well, so I’ll install and try again.

Looks like they are having some font issues or something. I did go over to the tabs and while I could not read it, everything seemed to layout in the same places as RDWorks when I compared them side-by-side. So yes, it does look like it has the rotary set up.

So it appears that the solution in RDWorks is to go into Vendor Settings and change the Step Length. To get this number, they have a button you click on and it pops open a dialog box where you enter the Requested Distance (as per the drawn design) and the Actual Distance (actual measured distance). This appears to be similar to the Calibrate Axis Button under Machine Settings in LightBurn.

We have that feature in LightBurn as well (calibrate axis in Edit > Machine Settings) but it’s not the same as using the built in rotary support in the hardware.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.