Still having NO LAYERS selected issues when framing and Out of Bound errors

This time I am using my rotary and I have drawn a test pattern to tune my axis rotation and I have drawn a 4mm x 270 mm rectangle. When I click frame, I get the following error, which is not accurate based on the image. Why is it doing this still?
There are also addtional issues with being out of bounds. Even though I have rotary enabled and the out of bounds check disabled in the machine settings I get the error in the second image when I try and run the job and burn the rectangle.

The second warning is from Lightburn advising just what is says. You can see the work area is smaller than your drawn object. What part do we need to clarify.

I’m suspicious of you running in absolute coordinate mode. Generally you can’t get the rotary at position 0, 0. You end up having to set your design somewhere on the work area to align it.

Might want to set the ‘rectangle’ to line, no reason to fill and line gives you a more easily measured rectangle.

I run all my rotary projects with User Origin.


Why would there be a boundary limit when Rotary is enabled since there is generally no limit on the Y axis, so your assumption there on the second image seems inaccurate.

As for the first image, the fact that it says no layers are set to output is a design flaw at the very least since the layer is clearly set for output. If absolute coordinates are the culprit, it should reflect as much in the dialog.

I don’t see anything from the screenshot.

Maybe @Lightburn can answer the no output issue. Would you mind posting the offending .lbrn2 file?

I’d like to try and reproduce it… as I’m sure they would…

The machine will stay within the defined work area. Most of these controllers don’t need to ‘know’ what’s out there, it’s just the same axes it’s always used, only you know it’s—
a rotary.

All of these machines count steps. It cannot count to infinity. It’s ‘steps’ are going to ‘roll over’ at some point, then it’s essentially ‘lost’

I have a Ruida and the it’s only options are

Screenshot from 2022-03-28 07-18-55

Never had a rotary for my grbl, but I know of nothing in grbl that allows for rotaries, but that doesn’t mean there isn’t.

Maybe we can get some others that have your setup and dealt with this.


Let me see if I can make it a little clearer on the first image.

The software does know it’s a rotary hence the point of ensuring that Rotary Enabled is on when using a rotary, which I am pretty sure how LB knows to use the A axis or the Y Axis in the settings you have selected. And I am pretty sure that in LB when Rotary Enabled is on it also knows that it cannot use the machine boundaries (at least in the Y axis) or no one would ever be able to laser tumblers for example since most 30oz are around 310mm in circumference and this would pretty much eliminate all K40’s unless they were modified to 12x24 or something.

As far as the providing the project file, it’s pretty simple. It’s just a rectangle that had a width of 4mm by a height of 270mm.
I do not save these simple calibration projects since they are so simple. Sure, it would be easy for you to create one to match what I had.

As I said, I don’t see anything from the screenshot that would explain the output issue and the Lightburn people will have to get you an answer.

Works fine for me.


Hey Dominick,
What happens if you make that box smaller so it fits within the boundaries of of your workspace?

Do the errors both still appear?

You likely have this enabled in your settings:

That would probably be the culprit. Didn’t even know that option was there since I hardly ever click the Disk button to display those options and would have never thought to look in File Settings for something like that. I thought the “Enable out of bounds warning” was causing it somehow and disabled that, but it didnt help.

I think the problem here is he’s confident the Y axes size is disabled/not important with a rotary.

It can rotate infinitely.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.