Still having this odd issue - can anyome offer advice?

Try putting scan angle at 90 degrees. It might be a workaround for your issue.

Is your fill bidirectional?

I can see you have a “Ruida”, but what kind of machine it does not say. The series you have made and show here have you compensated your power for the speed and vice versa? Do you have a sense of how fast the pulse time from your laser machine is? 12000 mm / s is very very fast in my optics.

Do those numbers in your photo have units? 200 what?

Tried that. but unfortunately, it just means the horizontal lines become thin or don’t etch at all if that makes sense


Not sure what the pulse time is?! Is it something I can change?

btw, its a Ruida 644XS apparently :smiley:

btw, the 200-25 is the speed of the laser, not the power,

Hi Hank, thats the speed - the power ranged from 15-40% output depending on the speed of the laser

Well, yeah, I figured it was speed. But what’s the units man?
200 K/h, 200mm/sec, 200mm/min, 200 furlongs/fortnight?
200 by itself is a meaningless number.

1 Like

Ahm, sorry, got you know

Its mm/sec

It was more theoretically meant that some time is needed to start and stop the laser itself.
I’m probably a bit handicapped with my little K40 and therefore do not quite understand that people with their machines can drive at 43.2 km / h! I have seen machines for many thousands of dollars which are super fast but can an ordinary cheap Chinese machine run properly at this speed in the long run?

Well 200 mm/sec is certainly not particularly fast. I see the same sort of thing with my 80w/ruida machine but it doesn’t become much of a problem until well over 400mm/sec.

It may be that your HV PS is kind of sluggish. Dunno.
Just for curiosity, whats the wattage of your tube and what power are you using on those samples?

So, turns out my tube is 40w, yet my PSU is a 50w (MYJG50W)

I think the black-red-larger machines have a completely different transport system with proper belts and slide rails, it can not be compared to a standard K40 with their small plastic rollers and thin and narrow belts.

So still dont know whats causing this

It seems to me the trigger to fire is slow, and if its moving fast by the time the trigger powers up its already sent the comand to deactivate the laser.

As a silly test I ran it fast, put some paper, them my finger under the laser and it was clear it wasnt fireing. Slowed it down and gradualy, and slowly it was fireing again. The slower it went, the better the results.

Its either the PSU, or the controler. I just wish I know which.

Hi, i think i found the issue.
I bought my machine recently and i’m new to lasers so it took me a while to figure this out.
i tried resetting all settings in lightburn, reïnstalling etc → same issue.
i then tried RDworks (came with the machine) → same issue.

so it had to be a machine issue.

i tried to tightening belts, lube guide rails etc, no change
i realigned the laser again, it had not deviated (visibly) from when the machine was just bought.

then i turned my attention to the powersupply, down the rabbit hole.
i tried to get the wiring diagram to my specific laser from the manufacturer, but have not recieved any answer yet.
i went on my own and looked up parts numbers etc to figure out myself what the wiring should look like.

on the website of cloudray i found my exact psu:

its branded ZYE but that is the direct manufacturer of the device, cloudray rebrands them as their own.

the wiring diagram to this power supply is different from the other types with only 2 connectors.
i compared the wiring diagrams and found out my PSU was wired for the wrong type of PSU.
I rewired the PSU and ruida (changed from analog to PWM also)
and tadaa! laser works like a charm, very accurate, does not skip thin parts or anything, Ican engrave at 400mm/s 20% on test piece of cardboard with no issue.

I guess the manufacturer of my laser recently switched PSU’s and dit not update their wiring schematics in the assembly line.

TLDR: check PSU wiring + switch to PWM-signal instead of analog

PS: Don’t touch the wiring or anything inside the psu/controller part of the laser before unplugging it completely from the grid!

1 Like


the problem you’re having looks very close to mine! and you’ve fixed it!!!

Im going to check my wiring on the weekend I think. I don’t have time right now, unfortunately. Out of curiosity, if yours one of the orange co2 lasers. I think they are the “newer” models and that’s what I have. Would be funny if they all came from the same factory with the same problem

“PWM-signal” is that done via LB?

Also, where did you find the wireing diagram, could you post it>

btw, my PSU is a ZYE too, but a slightly different model - the MYJG50W

Now just to be sure it works try the finger test again!

Don’t really do that. edit- meant for MattyD.

I added some files to help you figure out the wiring, and yes i have the orange kind of laser.
also the PSU i linked is not the one in my system, but has the 3 connectors like mine.
mine is the same as yours i guess (MYJG50W)

the PWM input for the PSU is generated by the RUIDA, not LB. it gives output on pin LPWM1 (3rd pin on the ruida CN5 Connector).

Hope this helps, good luck!


Fantastic! thank you! Im going to look into this on the weeked

and that looks identical to my machine too!

mate! you nailed it!

Just spent 10 minutes checking the wiring and mine was incorrect too. Swapped the bits around (as per your diagram) and it now works!!

Compare this new image with the one I posted originally. The top two are 200mm/sec the bottom two are 400mm/sec - and not a single thin line is missing! :smiley:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.