Stopping a wiggle when the laser changes direction

Hi all! I’m new to Lightburn, just a few days in.

I have a k40 and just installed a Mini Gerbil so I could go the Lightburn with camera route. I’m finding it very intuitive however I can’t work out how to get rid of a little line “wiggle”.

I have included pictures just on the logo one you can see it a lot on all sorts of places and I thought it was something to do with the rails in the machine but I’ve checked it all over and mentioned the belts and oiled the oily bits and it didn’t go away so I did a load of zig zags all over some card as you can see in the other picture and it became pretty obvious its happening when the laser head changes direction.

So my question is, is there a way for dealing with this in the software? I feel like there should be given the overscan feature for fill is for a very similar issue but I can find it.

Also if you think it’s something else causing it, feel free to tell me, I’m totally aware I’m relatively new to this.

Thanks in advance!


Have you thought about backlash?

Don’t know about your controller… :smile_cat:

Thanks for the reply

I wouldn’t rule backlash out but there doesn’t seem to be much in that regard by feel when the motors aren’t engaged. Also, unless I’ve misunderstood if it was backlash on either or both of the axis then it would cause come misalignment issues on things like fills and I don’t see any of that.

I also think its caused by the acceleration being too high as it changes direction because if I do it while running the machine is running VERY fast the wiggle gets even larger and looks like a dampened waveform which reads to me like it still got momentum in an opposing direction and causes the head to wobble a bit from side to side until the energy in the alternate direction is gone.

I feel like there is something hidden in the software to allow the machine to slow down or overshoot direction changes but I can’t see it or don’t know what its called if it is there.

Very probable. Max acceleration in that axes can be an issue. You’re probably right about the backlash…

Might try limiting the acceleration for a run and see if you get an improvement… Should be an easy check :slight_smile:

Don’t know if this would effect that, but take a look at setting overscan.

Good luck :smiley_cat:

Thanks, I’ll check that out :slightly_smiling_face: