Stopping problem during processing

The board is being tested after changing from m2 nano to mini gerbil3.
The simple test file could be processed without any problems, but when I try to cut a more complex shape, it still stops in the middle.
I tried increasing the step motor current, but it didn’t improve and the symptoms were the same.
Most other methods have failed because the grounding is good, the PC is not in sleep mode, and basically it works well and then stops.
During processing, the movement stops and the laser keeps coming out.
At lightburn, the progress bar keeps going up.
Even if it stops, it does not stop, and even if the usb connection is disconnected, the laser continues to come out when connected again.
To stop the symptoms, press stop at lightburn and manually move the laser head slightly, and the released motor locks and returns to normal.
Does anyone have the same symptoms?
Please tell me how you solved it.

There is a video about abnormal symptoms, so please check it.

This type of thing is almost always going to be a communication fault. Have you reviewed Awesometech’s troubleshooting guide?
MG3 debugging – inconsistent operation – AwesomeTech

There are similar posts on this forum and in LightBurn documenation:
Connection Issues - LightBurn Software Documentation

Here’s a video that covers common diode laser issues but are also applicable to most K40 conversions.

Ground - Checked
Belt - No Problem
sValue maximum and $30 - 1000 for both
Set to $32 - 1

The only thing I haven’t done yet is to change the short usb cable and the extension hub to another cable.

You’re using a USB hub? If so, remove this and retest. Those are notorious for causing issues.

And in my case, the USB connection is not broken, but the progress continues to go up at lightburn.
The same result came out even after testing without herbs.
When the motor is released from controller control and can move, it stops, and when the head is slightly moved with the hand, the work is controlled by the controller again.

If you look at Console can you see a welcome message again when that occurs? If so, it may just be reconnecting. Or more likely, your controller may be recycling. This can often occur with static discharge through the USB cable.

One thing to try is to enable “Enable DTR signal” in Edit->Device Settings. I didn’t think that MG3 board required that but give it a shot to see if it makes a difference.

I changed the usb cable and the symptoms are still the same.
I don’t see the “Enable DTR signal” menu you mentioned in the device settings.
And the console says it can’t detect 5v.

Ah… I didn’t realize that the Gerbil-STM profile did not have that option which throws that out.

Try changing Transfer mode to Buffered.

Can you confirm that the laser is turned on? Note that the controller can likely get enough power through USB to power the controller.

Check out the LEDs on the board. Do you get LED8 active green?

MG3 LED indicators – AwesomeTech

This is a picture of the board when there was a problem.

This is a picture when it is being cut normally, and all the led lights are on.

Even if I processed a simple shape because I thought there was a problem with arc tolerance due to the complicated shape, the problem remained.

I added a video with a problem in the text, so please check it out.

Not clear to me if the lack of 5V is the issue itself or is an effect of the root cause.

Make sure your cable from the LPS to the board is undamaged and in good order. It’s possible a connector is loose or damaged. Make sure there’s a solid reliable connection.

Else, it’s possible that you’re getting interference of some kind or you still have a grounding issue. Did you review the grounding guide and mounting guide for the board:
K40 laser grounding instructions – AwesomeTech

  • Mounting – ensure MG3 is mounted via the provided plastic standoffs, rather than steel bolts on the K40.

I took a look at the video. Looks like your steppers are missing steps. A few possibilities:

  1. your speed or acceleration is set too high; you may want to test slower acceleration or speed to see if this addressed that problem
  2. your stepper driver settings are set to too low a current for your stepper motors

I believe the MG3 is typically setup for K40 conversions which have small stepper motors. Your laser looks larger. It looks like this is adjusted through a potentiometer on the driver. I suggest making a mark to indicate the default position before making any changes. Or at least taking a photograph.

Adjusting stepsticks – AwesomeTech

  1. Low speed did not improve the problem, and this speed was used when using nano m2 board.
    (Cutting is a speed of 15-20 mm/sec.)

  2. I tried to increase the current of the stepper driver, but the symptoms were the same, so it returned to the original current.
    (My laser cutter is not a k40 but a Chinese device using reci90w.
    There seems to be no big difference from k40 using nano m2 board.)

  3. It is not a short problem because it is not mounted yet and is placed on a wooden board.

  4. LO is well connected to the TL terminal. If it was not connected well, there would have been a problem with the laser source itself.

  5. The ground connected to the laser equipment is connected to the window chassis. When using nanom2 board, there is no problem with grounding. The connection between the power supply and the window chassis was also confirmed through a multimeter.

I don’t know what to check anymore.

Try lowering acceleration as well. These are $120, $121, $122 in Edit->Machine Settings.

I wonder if this is causing its own problems.

You may want to request support from Awesometech. On your general symptoms but also specifically on causes of the 5V message and LEDs 8,9,10 going off.

Did you try switching to buffered transmission?

  1. The symptoms were the same even though the transfer mode was changed to buffer.

  2. $120 : 8000 → 6000
    $121 : 3000 → 2000
    $122 : 3000 → 2000
    As shown above, the symptoms were the same even though the acceleration was lowered.

Is there any change at all to the behavior? Or it’s exactly the same?

What happens if you dramatically further reduce acceleration and speed?

The video showed very classic symptoms of skipping motors. It’s possible there’s another root cause but want to for sure eliminate this as a possibility.

Also, do you know the specifications for the stepper motors? Are you able to take a picture of the model number or rating?

What software are you using when used with M2 board?

I replaced these cables with shielded.

  • limit switches
  • signal wires from controller to motor drivers
  • wires from motor drivers to motors

all cables are separated and don’t follow the same paths

all star earthed, shields only earthed at one end.

40V power cables (from 2 separate supplies) to motor drivers are separated and capacitor bypassed at the driver terminals.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.