Strange filling behavior, line keeps standing where laser starts

Hey everyone,

I am trying to figure out, what causes this strange behavior: When filling a shape (does not matter what kind of) a line a few millimeters from the etch appears.
This appears only in the direction from the start of the laser firing. So when using uni-directional filling, I get one line to the right. For bi-directional, I get two (see pictures).


(bi-directional filling)


(uni-directional filling)

The line seems to look like the material is not totally blown / lasered away, like there is a drop in laser power or something… This behavior occurs on all materials. But for oak it is more visible.
What I tried so far:

  • Changing power / speed → more or less the same
  • Changing the interval → not changing much
  • Manually applying air assist to the laser → same result

So I am running out of ideas what the problem might be… Has anyone some suggestions?? The occuring line is really annoying and looks terrible on a laser job! Thank you for any ideas / help.

PS: Here are the controller settings of my Ruida644XG

1 Like

I do not know your machine but it will surprise me a lot if it can speed up and down at this speed you have chosen.
Try at 2500mm / min.

Hey, the speed I am using is fine. So around 400 to 500mm/s. 2500mm/min would be only ~40mm/s. This is way to slow for the maschine for engraving. For cutting it is fine…

Hi I am having the same problem. I’m using an ortur laser master 2 Pro and I am getting this same deep burn line about 20% into a burn no matter what direction or material I use. Its driving me mad :angry:. Just wrecks everything.

1 Like

Hi, are you using overscan? if not, select it and try 5% or so, that may help.
It’s in the cut/layer panel.

‘Overscan’ is handled internal to DSP controllers. Different from GCode @Kris1 :wink:.

1 Like

You are not having the same issue. You are dealing with an entirely different motion control and laser system. Look to ‘Overscanning’ setting for your fill layer on GCode setup.

@hummelbruch, for your Ruida setup, looking into the ‘Scanning Offset Adjustment’ is worth review: Scanning Offset Adjustment - LightBurn Software Documentation

Scanning Offset Adjustment

Modern lasers are capable of moving very fast, and with remarkable precision, however firing the beam still takes time. Some power supplies and tubes may respond in microseconds, but others take longer. At higher speeds, belts will pull slightly as well, and all of these things can cause the output of the laser to shift slightly when engraving.

@Rick Thanks, I already did. This is not the issue. I adjusted the Scanning offset. Also the sqaures have the right dimensions… I also thought about this, but I have done some extensive testing to find good matching parameter to adjust the offset. I don’t know why this keep happening…

(the tests for the adjustment)

I am realy green at all this, it didn’t seem to do it before the update on lightburn. I used all the settings lightburn recomend and this is the outcome…


And these are the settings…

bonjour a tous
vous avez acheter un laser ave un logiciel de travail qui peut etre autre que Lightburn
pour ma part c’est RDWork
faite un test sur votre logiciel de travail autre que LB pour vous rendre conte si vos lignes sont apparente

Hey, good idea… I will check this when I am back. But the recommended software for this laser is actually lightburn. But I will take a look if this behavior also accurs using RDWorks…

So I tried RDWorks… but, the result is the same. I used the same settings as for Lightburn… Any further ideas? This is really annoying!

Thanks for your support and help

(Results using RDWorks with same parameter, all squares are filled at the same time)

Has someone any other ideas how to solve this problem? Or to get to the causing problem in the first place?
I guess there is an issue with the power of the laser when firing it up… I do not have any other possible solution to that anymore