Strange glitching issue with endstops / safety switches

I just got my 50W laser (with Ruida 6442s controller) last week and I’ve been fixing some wiring issues and doing some upgrades. One of the things I did was add a door safety switch.
By itself it works (although sometimes it seems that there is a bit of a delay when it’s triggered or released), but it seems to suffer from interference when one of the endstops is triggered.
For instance, when I close the door, the status of the input changes to “not active”, but if I trigger the z-axis endswitch, the door status changes to “active” and stays that way until I open and then close the door again:
I’ve tried to eliminate things like faulty wiring by eliminating the switch all together and putting in a jumper wire from the ground to the door safety input on the controller, but it still happens.
I’ve also tried connecting all the ground wires in case there might be some difference in potential, but to no avail.
Does anyone know what might be the issue, or could it be that my controller is just faulty?

It is most likely (could be) bad / cheap switches (if they’re magnetic - could be interference) or wiring. I would suggest that you eliminate the door switch and Z switch completely and then add one at a time. Fully test the outcome, ensure it operates as expected, and then add the next one. It is highly possible that if one switch is affecting the other, there is a wiring issue at the controller.

I used a Schneider electric XCKP2145P16 for the door, so not a cheap switch (I actually changed it out with another one, which didn’t solve the problem). Also put in another cable, just in case it was a break in the wire. Even tried eliminating the switch and just connecting the wires together using a wago connector, also to no avail. The switch on the Z was the original one in the machine. I haven’t switched that out, as it wasn’t giving me problems. Could be that it’s causing interference, but why just on the door switch input? I’ve got an inductive sensor on the way that I’m going to switch it out with, so we’ll see if that fixes the problem. I checked the wiring multiple times (I actually did a complete rewire on the machine, because I didn’t trust it) Pretty sure that’s not the problem.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.